Prusa i3 hephestos laso infinito despues de actualizar el firmware



  • Saludos a todos.

    tengo  una prusa i3 con una Frearduino 2560, sucedio hace pocos dias actualize con una versions de repetier para marlin y quedo frizada y despues de researla esta que no carga el firmware y con ninguna aplicacion me permite subirle ningun otro. lo he intentado con cura, con repetier, con arduino al conectarla a mi iMac o a una PC, se ve que esta conectada al puerdo pero no sincroniza.

    Alguna idea?


  • MVP

    Cuando dices que está conectada al puerto, has probado de abrir un terminal (desde Arduino, por ejemplo)? Qué sale?



  • me explico mejor:
    la tengo instalada a mi imac, no a una PC con windows; en Windows saldria conectada a COM1 .. COMx., en los OS de Apple, los puertos toman nombres imagino que basados en algun dato grabado por el fabricante, solo cuando se la tengo conectada arduino dice algo asi como /dev/tty.?????/ los signos es porque no recuerdo ahora mismo las palabras exactas es el identificador del puerto para este board frearduino 2560. es por eso que afirmo que se ve conectada a su puerto. y si desconecto el cable usb pues desaparece como es logico. le leido quie se necesita quemarle al cargador de esa tarjeta. solo que he leido 2 variantes. una es con un programador atmel y otra es con una tarjeta arduino o frearduino 2560 y hacerle unos puentes en los pines de comunicacion y entonces la tarjeta que funciona logra quemar el cargador en lo que esta loopeada. ahora no dispongo de nunga de estas variantes. es por eso que he posteado aqui.


  • MVP

    Entiendo que crees que tu placa freeduino no tiene el bootloader arduino cargado.

    Normalmente cuando compras las placas Arduino, ya vienen con bootloader instalado.

    Has probado de cargar un programa? Por ejemplo el blink? Cuando cargas, qué te dice Arduino?



  • Si lo he probado, y no funciona porque no sincrinizan. esta frearduino normamente sincroniza 115200, cuando le cambiaba el la velocidad no se conectaba por espera una conversacion a travez de puerto COM en Windows o Similar en MAC a su velicidad que es 115200; ahora por alguna razon su bootloader cambio o esta dañado y no puedo sincronizar para subirle un nuevo bootloader.

    Mi pregunta sigue siendo es posible subirle un bootloader sin necesidad de AVR adicional (Otra tarjeta Arduino)?

    Amigo Lucky estoy en America, mas especificamente en Cuba, o sea si estas en españa te nemos aprox 6 horas de diferencia. y No tengo internet en la casa. sera posible que me escribas a mi email y mantener esta conversacion a terminos mas frecuentes por que casi 24 hora entre cada lectura. mi email es josephotoservices@gmail.com.

    Gracias por adelantado


  • MVP

    Te escribo mañana al mail.
    Tengo entendido que no es posible cargar un bootloader sin un programador o Arduino. Mañana lo investigo.



  • Lo logre ya tengo mi Frearduino trabajando nuevamente con Marlin instalado.

    Aunque esta funcionando tengo dudas de cómo lo resolví si es que fue así, me explico mejor:

    La Frearduino 2560 + RAMPS 1.4 vino originalmente con mi Prusa i3 de HEPHESTOS, siempre la he tenido conectada a mi iMac utilizando software de Mac como el Cura, Repetier Host y Arduino IDE; después que se quedo lupeada acudi Uds.  Y busque en la red cada tutorial he información al respecto que coincidían en lo mismo cuando se trata de Mega 2560. Minutos antes de estar a punto de comprar un programador decidí hacer el mismo procedimiento desde Windows 7, así que monte en mi iMac  una maquina virtual he instale Windows 7 y  Arduino, conecte los cables desde ICSP y al primer intento se Flasheo el Bootloader perfectamente; la desconecte de los cables ICSP y le puse directamente el USB y le subí el Blink y funciono, seguidamente subí el Marlin y esta como en sus viejos tiempos (Todo esto desde Windows 7 en mi maquina virtual), ahora salgo de Windows abro el Arduino IDE para Mac Cargo Marlin o u Codigo y le doy a la ventana del terminal y se ve como comienza a inicializarse el Marlin instalado en ella; pero si intento subir algo sencillo como un Blink obtengo el mismo error avrdude: stk500v2_command(): command failed.   Pudiera decirse que tengo problemas en Sierra(Sistema operativo de Mac basado en Unix) con la instalación del  stk500v2 pero hago la misma operación con la placa Key Studio Mega 2560 y funciona de maravilla.
    Hasta ahora solo puedo subirle sketch desde Windows 7.

    Alguna Idea?



  • Gracias por todo el saoporte


  • MVP

    Me alegra que hayas solucionado.
    Ayer estaba intentado recuperar un Arduino uno y me pasaba parecido a ti.
    Al final cambiando el programador de puerto USB me funcionó.
    Cosas de la informática.



  • Asi es my friend, tuve un compañero de trabajao que no era informatico y muy sabianmente me decia la Informatica no es una ciencia exacta!!! amo de chiste y no hay un dia que no lo recuerde.



  • Saludos atodos especialmente a Sr LuckyLuck,here we go:

     

    Mi Prusa i3de Hephestos, llamémosle la primogénita de esa línea perdió el bootloader mientras subía un sketch de Arduino exactamente el Marlin 1.0 con algunas modificaciones en sus constantes. Esto lo había hecho cientos de veces perfectamente y como decimos acá “¡Pafata! Un palo por la cara” el bootloader de la Frearduino Mega 2560 se quedó en un laso infinito. He aquí como lo resolví. Con una Mega 2560 de Keyestudio las cablee así y con arduino IDE le queme el bootloader nuevamente y al instante Vuala!!!  Todo Bien.

     

    Debo añadir que he trabajado siempre mi prusa desde una iMac, nunca desde una PC y nunca me sucedió algo parecido; y al hacer mis tareas mientras duro este incidente descubrí que es esencial que funcione correctamente el JAVA no importa en la plataforma que trabajéis. Siempre supuse que Arduino IDE y el resto lo hacían a bajo nivel Assambler o C++, pero para mi sorpresa es JAVA, wow mi respeto para JAVA.

     

    Espero sirva a alguien. Si necesitan contactarme les dejo mi email ya que aquí en La Habana, Cuba donde vivo no tengo internet en la casa o el movil y debo ir a una sala de navegación y me queda un tanto distante.

     

    Jose

    josephotoservices@gmail.com

     

     


  • MVP

    Muchas gracias por compartir la solución, y esperamos que sigas por el foro, siempre se aprenden cosas nuevas. Un saludo!