Galería no se actualiza sin reiniciar



  • Buenos días.

    Cuando muevo imágenes de la memoria del teléfono a la microSD o de microSD a otra carpeta de la microSD, al entrar en Galería no se visualizan los cambios. Para que surtan efecto tengo que reiniciar el móvil. He probado a hacerlo con el gestor de archivos nativo y con otros que he instalado de la Play Store, todos con el mismo resultado.
    Tampoco aparecen los cambios en Google Fotos.
    Este comportamiento no se si es normal o hay algún fallo de software.
    Tengo el terminal actualizado al último firmware y también todas las app.


  • Moderador

    Hola,


    @{JorgeT} Si mueves archivos dentro de la propia memoria interna (sin tocar la SD), ¿tienes el mismo comportamiento? ¿Has probado con otra tarjeta SD para comprobar si reproduce el mismo comportamiento?

    Un saludo,



  • Cuando muevo las imágenes dentro de la memoria interna se actualiza la Galería sin problemas. No he probado con otra tarjeta SD, la que tengo es relativamente nueva.


  • Moderador

    @{JorgeT} Prueba con un formateo de la tarjeta para ver si hay algún problema con el enrutamiento. 


    Un saludo,



  • ¿El formateo se lo hago desde el ordenador o desde el teléfono?


  • Moderador

    @{JorgeT} Te recomiendo que guardes toda la información en el PC y formatees en FAT32. Mejor si haces el formato completo y no rápido. Coméntanos los resultados.


    Un saludo,



  • Probaré a hacerlo.

    Otro dato. Si desmonto la tarjeta y la vuelvo a montar sí me aparecen los cambios


  • Moderador

    @{JorgeT} En ese caso, es probable que por la velocidad de lectura de la tarjeta, tarde un poco en mostrarse los cambios en la ruta de la tarjeta. Prueba a hacerlo y espero un poco para comprobar si la ruta se actualiza y muestra los cambios.


    Un saludo,



  • Antes de nada, decir que tengo un X Plus. Me confundí al etiquetarlo.

    He formateado la tarjeta desde el teléfono. He movido una imagen de prueba a esta y sigue el problema.

    Es como si no sincronizarse la galería cuando se usa la tarjeta. También he esperado para ver si la galería de actualiza sola, sin resultado.

    La tarjeta que tengo es de clases 10


  • Moderador

    Buenos días, 


    @{JorgeT} muevo el hilo al subforo del X5 Plus 😉 

    Si con la memoria interna va bien, probablemente sea cosa de la SD. ¿Tienes la posibilidad de probar con otra?

    Un saludo.



  • Intentaré probar con otra que me presten y os cuento el resultado.


  • Moderador

    @{JorgeT} quedamos a la espera 😉



  • Este problema también le tengo yo. 


    Si me descargo una foto de chrome, que se descarga en la memoria interna, y después la paso a la tarjeta sd si no reinicio no sale en la galería.
     
    Me pasa con cualquier tarjeta SD.

    Os dejo un video.


    Salu2!!



  • Acabo de hacer la prueba con otra tarjeta. Sigue el problema.


  • Moderador

    @{juanxo1} gracias por el vídeo 😉 ¿Qué modelo de SD tienes? ¿Con cuáles has probado? Si todas son similares, es como si no se hiciese la prueba. Necesitaríamos saber más información.


    Un saludo.



  • Pues he probado las siguientes:


    Dos Sandisk Ultra 32GB SDHC UHS-I Clase 10 A1
    Sandisk Ultra 64GB SDXC UHS-I Clase 10 A1 (Esta es la que uso actualmente)
    Samsung Evo 32GB SDCH UHS-I Clase 10 
    Transcend 32GB SDHC UHS-I Clase 10
    Transcend 16GB SDHC Clase 4

    Se que algunas son parecidas, pero es que me falla con todas.

    Salu2!!



  • A mí también me ocurre



  • Que tarjetas usáis los demás??

    Salu2!!



  • SilverHT MicroSDHC clase 10 UHS-I 16GB



  • Buenas tardes.

    Acabo de probar otra aplicacion de galeria y me funciona perfectamente, asi que supongo que el problema es de la app de galeria nativa.

    Salu2!!