Error al flashear firmware a Hephestos



  • Hola, como están?


    Estoy tratando de flashear el firmware 2.5.1 a mi impresora pero no lo estoy consiguiendo.


    Y lo que veo ahora en el display del lcd es esto: http://i64.tinypic.com/1zv9zj9.jpg

    Mi impresora es una hephestos(a secas), https://www.bq.com/es/support/hephestos/support-sheet y lo estoy haciendo en Ubuntu 16.04 con arduino 1.6.5 descargado en ~/arduino como indica en la doc

    Puede ser que me esté faltando algun paso?

    Gracias!


  • MVP

    Te da algún error en compilar? Solamente los has probado una vez?
    Has probado de arrancar la hephestos sin estar conectada por USB después del flasheo? El flasheo, lo has hecho con la alimentación de la impresora en on?



  • Si, el flasheo lo hice con la alimentacion en on. Puede ser que lo debía tener apagado?


    Volvi a intentarlo varias veces sin exito.

    Gracias!


  • MVP

    Prueba sin alimentación, no sea que interfiera.
    Puedes seguir usándola o se te quedó con la pantalla en blanco?



  • Luego de un rato probando descubri que el problema estaba con la version de firmware que usaba. Flashie una mas vieja, 2.5.0 y funciono.

    El problema que tengo ahora es que no me reconoce los finales de carrera. Los motores siguen moviendose por mas que esten a tope. Puede ser que tenga mal conectados los endstops?

    El firmware 2.5.0 lo instale con el .hex que esta disponible en la web de bq.


    Update:

    Luego de revisar los finales de carrera el problema era que estaban mal enchufados. Tambien logré flashear el codigo compilado de github, el problema era que estaba haciendo mal el make, la correcta era: 
    make hephestos_zum

    Pero como no aparecia en la guia de github inicialmente no la estaba usando.

    Gracias!