Problema con modo hdr



  • Hola. Veréis, tengo un problema con mi cámara. Yo tengo un bq Aquaris A4.5. El caso es que cuando hago una foto con mi smartphone, en modo hdr, sale a veces con "puntitos blancos", es decir, para hacer la prueba, hice una foto sin hdr tapando la cámara (con el objetivo de que saliera una foto negra) y la foto salió negra, como debe ser. Pero cuando activo el modo hdr y repito la misma acción, la foto sale con puntitos blancos, como si fuera un cielo estrellado. No es problema de que haya píxeles muertos en mi pantalla, ya he hecho pruebas al respecto, y tampoco es problema de la app de cámara, pues he probado distintas apps y pasa lo mismo. Ya he reseteado el móvil de fábrica dos o tres veces (por ese y por otros problemas) y se me solucionaron todos menos ese. Por cierto, el problema lo tengo desde que estaba nuevo prácticamente el móvil, y he de añadir que si le doy leves golpecitos por la parte trasera, se oye como si hubiera algo suelto por la zona de la cámara, aunque dudo que sea un problema de hardware, pues, como he mencionado, al quitar el hdr no me pasa.


  • MVP

    Hola
    Eso es normal dentro de lo que cabe. El HDR combina tomas con distintos ajustes de luminosidad para poder equiparar las zonas claras y oscuras de una toma, de modo que ambas se visualicen correctamente y no una demasiado clara y otra demasiado oscura. Su utilidad se maximiza en caso de fotografías con gran contraste luminoso, chino por ejemplo una zona al sol y otra zona a la sombra. En las escenas nocturnas i muy oscuras el HDR normalmente no da resultado, y además es posible que produzca el efecto que mencionas de ruido en la imagen.

    Un saludo



  • Muchas gracias por la explicación de la función del modo hdr, pero de todas formas, ya contaba con ello y solo suelo usar el hdr cuando es necesario, pero aún en esas ocasiones, hay veces que sale la foto llena de puntos. Si me pudieras indicar cómo insertar una imagen lo haría para que lo vieras.


  • MVP

    La tienes que subir a un servidor como Drive, Dropbox o similar, compartirla como pública y poner por aquí el enlace.

    Saludos



  • Vale, muchas gracias. En este enlace te he puesto, mediante Drive, dos fotos, una con la foto en negro y otra con una foto normal.

    https://drive.google.com/folderview?id=1eFurVxqjvCysZQpIOPgTt3vXF5HoHZfF



  • Por cierto, en la imagen normal, seguramente te aparezca con algunos puntitos, pero cuando la abro en mi móvil es exagerado, casi no se distingue el color en algunos sitios



  • Buenos días:


    @{bruce_dickinson} Es posible que aparezca un poco de ruido en la imagen al utilizar HDR en ese escenario en concreto. ¿Ocurre lo mismo es un lugar con algo más de iluminación?

    ¿Desde tu dispositivo la fotografía se se ve diferente a como la ves desde un ordenador por ejemplo? Si es así, es posible que pueda existir un error de pantalla. ¿Puedes hacer una foto desde un dispositivo externo, a como se ve en tu A4,5 para poder valorarlo?

    Un saludo.



  • Hola. Acabo de comprobarlo, y en otros móviles se ve mejor, igual que si abro la imagen en mi móvil desde la galería (Google Fotos), pero de todas formas, se sigue viendo mal. En la imagen que comparto en el enlace, el móvil de la izquierda es el mío, bq Aquaris A4.5, y el de la derecha es un bq Aquaris E5.

    https://drive.google.com/file/d/1Qj08zeIdS5RzyX2N17eiTc95jdIaqOct/view?usp=drivesdk



  • Por cierto, respecto a lo que ha preguntado MGuijarro, eso me ocurre en diferentes escenarios. He de decir que cuando no me ocurre, el resultado de la foto es muy bueno, pero cuando me ocurre, queda una foto inservible y muy decepcionante.


  • Moderador

    Hola,

    @bruke_dickinson No podemos consultar la foto que nos has enlazado. ¿Puedes subirla directamente o abrir permiso para comprobarla?

    Un saludo,



  • Por supuesto. Mira si aquí te deja, y también indícame si las dos fotos anteriores puedes abrirlas por favor.

    https://drive.google.com/folderview?id=14RNPELns40zQlRN3rWwB_F16soFaYoOv



  • Y si pudieras indicarme cómo subirla directamente desde un móvil te estaría muy agradecido


  • Moderador

    @{bruce_dickinson} Nos pide permiso para abrirla al ser un Drive. Para insertar la foto, puedes pulsar el icono cuadrado que tienes en el extremo derecho del cuadro de mensajes. Aparece como "Insert image". Si no aparece la opción en el móvil, puedes elegir la vista de escritorio para enviarla.


    Un saludo,



  • Pero ahí pide un enlace, no me deja seleccionarlo desde almacenamiento



  • Lo siento por mi ignorancia, pero esque soy nuevo en el foro


  • Moderador

    @{bruce_dickinson} Puedes hacerlo desde wetransfer como alternativa a Drive.


    Un saludo,



  • Está bien, aqui las tenéis.

    https://we.tl/Ckd5PCblee



  • @{bruce_dickinson} Muchas gracias por la información. Te recomiendo realizar un restablecimiento a datos de fábrica. Puedes hacerlo desde Ajustes > Copia de seguridad > Restablecer datos de fábrica.


    Durante la configuración inicial, no restaures la copia de seguridad de Google, es decir, configura el terminal como nuevo. Tras ello, únicamente con las aplicaciones nativas, verifica si el comportamiento se reproduce de nuevo.

    Este proceso borra los datos almacenados en la memoria interna, por lo que antes sería recomendable guardar todo aquello que no deseas perder.

    Un saludo.



  • Y no hay otra posible solucion? Lo digo porque, como ya comentaba antes, he hecho el restablecimiento de fábrica 3 veces por distintos motivos, y ese no se ha solucionado, aunque esas veces no lo hice desde cero. De todas formas, avisadme si hay alguna solución que no sea esa



  • Buenas tardes,


    @{bruce_dickinson} si no lo has hecho ya, prueba a borrar los datos de la aplicación de cámara y de los servicios de Google. Y si no se soluciona ni con esto ni con un restablecimiento sin recuperar la copia de seguridad de los servicios de Google, entonces lo mejor es que contactes con soporte.

    Un saludo y ¡felices fiestas!