SSR Calienta demasiado



  • Hola a todos, 


    Le he instalado una cama caliente MK2B a mi Prusa i3 con la siguiente configuración 

    El relé de estado sólido que he usado es un SSR 25DD y la fuente de alimentación es de 12 V. La configuración de marlin que tiene es la colgada por BQ en github. 

    El problema que tengo es que el relé se caliente mucho, muchísimo. Tanto que me ha llevado a comprobar el voltaje y he visto que entre los puntos de salida 1 y 2 hay unos 4V (Por curiosidad he visto los puntos de entrada 3 y 4 y tienen otros 4 V entre ellos), lo que quiere decir que a la cama sólo le están llegando 8 V de los 12 que da la fuente (comprobado que da 12 V).

    Entiendo que tiene que ser debido a un corto que hay en alguna parte y que no veo (sospecho mucho del propio ssr). 


    ¿Alguien podría encauzarme a alguna idea nueva? 


  • MVP

    El esquema parece correcto.
    Vuelve a medir tensión en la fuente. Luego sin el ssr mide la salida de la ramps(que va al ssr) y si todo es correcto, puede ser el ssr.



  • Pues he medido y desconectando los dos cables de la d8 del ssr no tienen potencial entre ellos.

    Lo que me ha resultado curioso es que entre el terminal 1 y el 4 del ssr hay continuidad, eso no debería de darse nunca no? Debería de estar aislado el input y el output.


  • MVP

    Si. Es raro.
    El relé debería estar sobre algo que disipe calor, es mucha energía que pasa por él.
    Algunos de los chinos, deben estar a masa o no van.



  • Tiene una placa de metal en la parte trasera que es la que disipa todo pero me temo que el problema es que hay un corto entre fases y eso hace que se lleve todo el voltaje.

    Sabes de algún sitio donde pueda comprar uno del que me pueda fiar?

    Si no me voy a plantear hacerlo con uno mecánico pero veía más seguro esto.

    Gracias


  • MVP

    Lo suyo es un ssr por la velocidad de rupcion del sistema pid.
    Yo he usado los chinos sin muchos problemas. Alguno ha muerto, pero al precio que van... Eso sí, uno me murió quedando abierto y casi me cargo el invento.
    En general en las tiendas de electrónica de tu localidad deberían de tener.



  • Lo normal es que se caliente un poco y ya no?

    Quiero decir que se puede tocar con la mano.


  • MVP

    Con una fuente de 24v dc y cama mk2 a 80° llega a calentarse que no se puede aguantar con la mano, unos 60-70°. Yo lo tengo con un radiador de PC antiguo, y aunque hay el ventilador no lo tengo conectado.
    Si vas a poner uno mecánico, en el firmware se puede tocar la velocidad máxima entre los pulsos, para que dure más y no haga tanto ruido al ratear.


  • MVP

    O puedes usar la propia salida de la electrónica, ya aguanta bien una cama normal, a 12V. Yo lo he tenido así mucho tiempo y cero problemas.
    Y si acaso te apañas un transistor de potencia por si se te funde poder cambiarlo, o una ramps completa.



  • De momento voy a probar con la fuente que tengo de 12V, un ssr40dd que he encontrado a precio asequible y le he comprado un disipador, a ver si es posible hacerlo así.

    Si no supongo que lo haré directamente con la ramps pero la idea era quitarle toda esa corriente y temperatura.

    Sabes si los relés mecánicos también se calientan?


  • MVP

    Se calientan, por la bobina. Y los contactos acaban muriendo de la pequeña chispa que se hace al interrumpir la corriente. Se puede poner un condensador entre los contactos de salida para evitarla en parte.
    Y hacen bastante ruido.....



  • Perdona que te moleste de nuevo. 


    Ahora estoy con el ssr nuevo y el problema que tengo es que la cama comienza a calentar según la enciendo, es como si no funcionase la señal de salida de los D8. 

    Hay que cambiarle algo al software además del 1 en #define TEMP_SENSOR_BED??

    He visto por ahí que algunos descomentan la siguiente línea pero no estoy seguro de que deba cambiarlo. 

    #define PIDTEMPBED

    GRACIAS


  • MVP

    Yo tengo el pidbed activo, es más estable la temperatura.
    Puedes mirar si te da bien la lectura de temperatura de la cama?
    Y el pin de salida lo tienes siempre activo?



  • La lectura de la temperatura la da bien porque en reposo da la misma que la del Extrusor.

    Acabo de probar sin el ssr y la placa de comporta igual: según la enciendo el LED de la cama se pone rojo y no para incluso después de llegar a la temperatura objetivo ( le he puesto 30 en un gcode para poder hacer pruebas rápido)

    El pin de salida debe estar siempre activo porque el led del ssr está siempre encendido.

    No sé qué tocar 😞


  • MVP

    Es raro. Qué modificaciones has hecho al firm?



  • Únicamente cambiar el #define TEMP_SENSOR_BED  a 1




  • MVP

    Has activado lo que comenta el artículo:
    Busca la línea “#define TEMP_SENSOR_BED 0″ y cambia el valor de “0″ por “1″ (sin las comillas).
    Busca la línea “//#define HEATED_BED_SUPPORT” y elimina las barras (//) que aparecen al principio de la línea, para descomentar el código y que quede activo

    También, has comprobado que la entrada de corriente la tengas bien? Las dos masas puenteadas y los dos positivo con corriente?



  • A qué te refieres con entrada de corriente? Ahora mismo lo tengo sin el ssr y me hace lo que te digo. Corriente tiene que tener tanto la cama como la impresora porque calientan el Extrusor y la cama. 


    Del fw he hecho esos dos cambios y seleccionado el lenguaje 5 en language



  • He vuelto a mirarlo todo y a no ser que tenga que hacer algún otro cambio en el fw creo que con el anterior ssr se me quedó cortocircuitado el mosfet de la ramps y se ha quedado abierto.

    ¿Hay alguna manera de comprobar esto?