Offset setting on Hephestos 2 with heated print bed ?



  • Hi everybody,


    I have an Hephestos 2 printer with the heated bed option and I can't figure out how to get a fine tuned and steady offset.

    First, when I do a hard reset with cold bed ( but heated bed installed under the plate), I can have the nozzle touch the plate to get the right offset.
    If then I level the plate in manual mode, disabling the auto-level function, all seems to be ok.

    But, when I launch a print, with the bed heated at 70° and above, the offset goes wrong, the nozzle seats around 3 mm above the plate.

    So each time I have to struggle multiple times with the offset tuning in the settings menu to get the right offset for my first layer.

    I have also try to heat the bed and do a hard reset, surprisingly when the bed is hot, I cannot have the nozzle go down to the plate it stops around 3 mm above it at the max offset correction of 5mm.

    I guess the induction sensor has some trouble dealing with the heated bed...

    Does anyone here has the same problem ? Is there a specific procedure to solve this issue ?

    Many thanks 😉



  • Me pasa algo similar. Desde que instalé la cama, siempre tengo que regular el offset al encender la máquina. Es una verdadera lata. Por no decir que tengo que ajustar un poco la cama. Y todo esto con el autolevel en off. Porque en on es un verdadero drama.



  • I have the same problem. Contacted BQ support and received a silly reply. Waiting for a real solution.



  • Creo que he encontrado la solución. A ver si me se explicar...


    Paso 1: Poner en OFF autolevel
    Paso 2: Ajustar cama para que este 100 % nivelada mediante el menú, con los 3 puntos de referencia utilizando el sensor.
    Paso 3: Ajustar offset de la forma habitual.
    Paso 4: Empezar a imprimir una pieza para que la base caliente se encienda y coja su temperatura.
    Paso 5: Cancelar impresión.
    Paso 6: Volver a ajustar el offset con la cama aún caliente.
    Paso 7: Imprimir la pieza. Debería estar correcta.

    Para las siguiente impresiones hay que calentar la cama previamente. Lo que significa iniciar una impresión para después cancelarla cuando la cama esté caliente. Y acto seguido, volver a imprimir correctamente.

    Sugerencia para la próxima actualización del firmware:
    - Esta claro que el sensor inductivo da lecturas diferentes si la cama caliente esta encendida o no. Se puede solucionar fácilmente el problema si se pudiera calentar la cama desde el menú para ajustar el offset correctamente.

    Espero que le sirva de ayuda a alguien. 


  • MVP

    Yo no tengo diferencias entre cama encendida y apagada. El problema tampoco se me reproduce con una secuencia clara. Estoy mirando posibilidades a ver si entre todos encontramos un patrón para poder centrar esfuerzos y solucionarlo.



  • Pues animo a los que tengan problemas a que lo prueben. Porque ahora si que estoy contento. Lo dicho, si en la próxima actualización dieran la opción de calentar la cama antes de iniciar la impresión de una pieza se acabó el problema.




  • Pues animo a los que tengan problemas a que lo prueben. Porque ahora si que estoy contento. Lo dicho, si en la próxima actualización dieran la opción de calentar la cama antes de iniciar la impresión de una pieza se acabó el problema.

    Gracias por la explicación, tengo exactamente el mismo problema y es una lástima que BQ no ponga solución inmediata a los usuarios. La verdad es que estoy muy descontento con la respuesta dada por el servicio técnico diciéndome que no tenían solución. Ruego a los señores de BQ que nos proporcione, a todos los usuarios de la Hephestos 2 con cama caliente, una solución rápida y efectiva o que nos devuelva el dinero de la compra del kit. Estaba muy contento con la máquina hasta la instalación de la cama caliente. Desde que tengo éste problema he pasado de usarla cada día a dejar de usarla por largos periodos de tiempo. Es una verdadera lástima.



  • I have the same problem. Contacted BQ support and received a silly reply. Waiting for a real solution.

    I also have the same problem and they told me there was no solution so far. I am really disappointed with them after this problem. I really loved the way this printer worked before heated bed was installed. I would like BQ too offer a quick and good solution for all of us or give is our money back.



  • So after many attempts, I guess I've found a "stable" way to have a good printing start allmost every time.
    Here is my procedure if it can help, I guess it depends on the room temperature :

    • Launch a print
    • when bed reach it's temperature, around 70°C for PLA in my case, cancel it.
    • wait it cool down for 5 minutes
    • restart the print, bed temperature should be around 45°C, (If it's over 50° the print get stuck at auto leveling pass, just turn the printer off and then start again)

    With that procedure I get the perfect Z Offset without tuning it each time, just one time 🙂

    I think that with a thermal sensor gun device I should see exactly when the bed reach 45°.


  • MVP

    So after many attempts, I guess I've found a "stable" way to have a good printing start allmost every time. Here is my procedure if it can help, I guess it depends on the room temperature :
    • Launch a print
    • when bed reach it's temperature, around 70°C for PLA in my case, cancel it.
    • wait it cool down for 5 minutes
    • restart the print, bed temperature should be around 45°C, (If it's over 50° the print get stuck at auto leveling pass, just turn the printer off and then start again)

    With that procedure I get the perfect Z Offset without tuning it each time, just one time 🙂

    I think that with a thermal sensor gun device I should see exactly when the bed reach 45°.


    Thanks for sharing your solution