Reporte de problema con BT y firmware 2.2.0



  • Buenos días,

    De nuevo el terminal vuelve a dar problemas con el bluetooth y el Audio20 de mi coche.
    Habilitadas todas las funciones de emparejamiento, el proceso com.android.bluetooth se detiene en el movil, perdiéndose la conexión.

    Si deshabilito "Usar para Audio multimedia" en las opciones del
    dispositivo emparejado, dentro de la configuración BT del móvil, la
    comunicación aguanta sin que se produzca este fallo, pero se entrecortan la mayoría de llamadas.

    He realizado un Downgrade al firmware 1.5.0, no ocurriendo ninguno de estos problemas, incluso alejando el movil 5 metros fuera del coche. Descarto problema de hardware.

    Os lo reporto para que lo estudieis por favor para futuras versiones, algo no ha ido bien en la última versión.



  • Buenos días:


    @{kantrico} Es posible que exista una incompatibilidad entre el dispositivo manos libres del vehículo y la última versión de firmware de tu BQ. 

    Con cada actualización de firmware intentamos mejorar en todos los aspectos posibles, e intentamos mejorar también en la compatibilidad con diferentes equipos Bluetooth. No obstante, es imposible que podamos asegurar el correcto funcionamiento y total compatibilidad con el 100% de dispositivos del mercado.

    De todos modos, ¿probaste el funcionamiento del terminal, al conectarlo a un dispositivo Bluetooth diferente? ¿Realizaste algún tipo de comprobación antes de volver a la versión 1.5.0?

    Un saludo.



  • Imagino que intentáis optimizar en la medida de lo posible, pero en temas de desarrollo de software ya sabéis lo delicado que es el intentar mejorar sin provocar daños colaterales.

    Antes del downgrade, lo enlacé a un manos libres de una radio Keenwood, no ocurriendo ningún problema o comportamiento diferente.

    Sería interesante si algún otro usuario con un Audio20 (Mercedes A, B, C, CLA, GLA, GLC,.... actuales) pudieran contar algo más. Es un equipo muyyyy extendido.

    También os comento que la primera vez que enlacé el movil al Audio20 aparecio un mensaje en el movil:
    "Peer supports advanced feature. Re-pair from peer to enable it", tanto con un firmware como con otro.
    En el primer intento con el firmware 2.2.0 hice caso y desvinculé el terminal al audio20, para volver a parearlo. A partir de ahí, todo problemas.
    Tras el hard reset (en 2.2.0), no apareció el mensaje de peer supports... Y vinculó bien a la primera, pero al cabo de unos días otra vez los problemas descritos.

    Con el firmware 1.5.0, me apareció el mensaje de peer supports..... pero no he querido volver a parearlo.

    Si os puedo ayudar en algo más, preguntad, soy el primer interesado en que podáis depurar el software.
     


  • Beta U Plus Oreo

    Imagino que intentáis optimizar en la medida de lo posible, pero en temas de desarrollo de software ya sabéis lo delicado que es el intentar mejorar sin provocar daños colaterales.

    Antes del downgrade, lo enlacé a un manos libres de una radio Keenwood, no ocurriendo ningún problema o comportamiento diferente.

    Sería interesante si algún otro usuario con un Audio20 (Mercedes A, B, C, CLA, GLA, GLC,.... actuales) pudieran contar algo más. Es un equipo muyyyy extendido.

    También os comento que la primera vez que enlacé el movil al Audio20 aparecio un mensaje en el movil:
    "Peer supports advanced feature. Re-pair from peer to enable it", tanto con un firmware como con otro.
    En el primer intento con el firmware 2.2.0 hice caso y desvinculé el terminal al audio20, para volver a parearlo. A partir de ahí, todo problemas.
    Tras el hard reset (en 2.2.0), no apareció el mensaje de peer supports... Y vinculó bien a la primera, pero al cabo de unos días otra vez los problemas descritos.

    Con el firmware 1.5.0, me apareció el mensaje de peer supports..... pero no he querido volver a parearlo.

    Si os puedo ayudar en algo más, preguntad, soy el primer interesado en que podáis depurar el software.
     
    El tema del Audio20 es que no tiene el firmware actualizable, aparte de presentar diferencias importantes sobre cada modelo en el que va instalado... Es posible que en algunas unidades de este equipo el teléfono se empareje por Bluetooth y en otras no. 

  • Administrador

    Buenos días,


    @kantrico Has comentado que en 2.2.0 las llamadas se entrecortan. ¿Te ocurre tanto en llamadas salientes como en llamadas entrantes? 

    Al llamara desde el terminal, no tienes ningún problema ¿verdad?

    Estaría genial que nos confirmaras el modelo exacto de coche que tienes y que nos facilitaras, si fuera posible logs y HCI Logs del problema. Te dejo los pasos para activarlos -necesitamos que ambos logs registren el problema a la vez; tendrás que activarlos de forma conjunta-.


    Logs

    1. Accede a la aplicación 'Teléfono' y marca el código ##837983##
    2. En este momento la toma de logs habrá comenzado.
    3. Reiniciar el terminal.
    4. En la raíz de la memoria del dispositivo se creará una carpeta llamada 'log'. Si disponéis de microSD la carpeta se creará en la raíz de la misma y no en la memoria interna.
    5. Reproducir la incidencia.
    6. Parar la toma de logs pulsando de nuevo ##837983## > Reiniciar el terminal.
    7. Compartir conmigo por privado la carpeta 'log'. Comprimir su contenido en formato zip o rar previamente.

    HCI Logs (logs específicos del módulo Bluetooth)

    1. Acceder a opciones de desarrollo (para habilitar este menú debemos pulsar siete veces sobre "Número de compilación").
    2. Activar la casilla 'Registro de búsqueda de HCI Blueooth".
    3. Al activar el Bluetooth del terminal se creará un archivo llamado 'btsnoop_hci.log'.
    4. Reproducir la incidencia.
    5. Compartir conmigo por privado el archivo llamado 'btsnoop_hci.log'.
    6. Para parar la toma de los HCI logs únicamente debes desactivar la casilla 'Registro de búsqueda de HCI Blueooth" y borrar el archivo 'btsnoop_hci.log'.

    Gracias por adelantado 😉

    Un saludo.



  • Me parece estupendo, no cierres el hilo por favor, para ir informando de manera global de los progresos.
    El entrecortado de llamadas se ha dado tanto con entrantes como salientes.

    Voy a volver a la 2.2.0 y voy tomando logs.

    A ver si en unos días tengo info útil.

    Gracias!



  • AdrianC, tienes un privado con info útil.

    impreza233, el firm de la radio es actualizable cuando a Mercedes le apetece, a los pocos meses me lo actualizaron por un problema con la SD del navegador.
    Si vas a pedirle que te lo actualicen por gusto, no lo hacen (probado en abril).

    Hay 2 modelos de Audio20, con y sin preinstalación de GPS.
    A su vez, 2 variantes para modelos de coche que tienen touchpad (como el clase C) y los que no tienen touchpad.
    El mío es sin touchpad, con preinstalación de GPS.

    Con un bq M4.5, funciona sin problemas, además de otros móviles de peor gama y otras marcas.
    Con mi U Lite funciona con el firmware 1.5.0.


  • Beta U Plus Oreo

    AdrianC, tienes un privado con info útil.

    impreza233, el firm de la radio es actualizable cuando a Mercedes le apetece, a los pocos meses me lo actualizaron por un problema con la SD del navegador.
    Si vas a pedirle que te lo actualicen por gusto, no lo hacen (probado en abril).

    Hay 2 modelos de Audio20, con y sin preinstalación de GPS.
    A su vez, 2 variantes para modelos de coche que tienen touchpad (como el clase C) y los que no tienen touchpad.
    El mío es sin touchpad, con preinstalación de GPS.

    Con un bq M4.5, funciona sin problemas, además de otros móviles de peor gama y otras marcas.
    Con mi U Lite funciona con el firmware 1.5.0.
    ¡¡¡Gracias por la información!!! No sabía yo de esta política de Mercedes-Benz, aunque no estoy aquí para hablar de otros sitios. Haz los logs de Bluetooth y comprueba dicho comportamiento que comentas, ya que, debido a que el manos libres funcionaba con el firmware 1.5.0, es probable que esto sea un aspecto del software del terminal que se tenga que pulir. Mándalos por privado al moderador, por supuesto.


  • He hecho pruebas con el firmware 2.1.0 y ocurre lo mismo, también os reporto logs de las pruebas realizadas bajo esta versión.

    Suerte!


  • Administrador

    Buenas tardes,


    @kantrico Gracias por toda tu ayuda. Ten en cuenta que si recurriremos a tí en caso de que necesitemos algo más de información 8-X

    Un saludo.



  • Perfecto, contad conmigo