Actualización 2.1.0 + 2.2.0 * SOLUCIONADO *