Calibrar acelerómetro



  • Buenas, ayer tratando de girar la pantalla para poder ver un vídeo en una página web me percaté de que el dispositivo por mucho que hiciese no giraba la pantalla, indignado he tratado de indagar por el foro y no he encontrado nada, el error se basa en que la pantalla simplemente, no gira, dejo aquí comprobaciones realizadas:


    Gmaps: me indica perfectamente la dirección a la que apunta el móvil
    en la app ¨sensor box for android¨
    acelerometer sensor: x: -19'6 Y: -19'6 Z: 14'5  todo en superficie plana, los vectores X y Z varian al mover el terminal,  el X varía muy poco, el z si aparenta marcar bien (siempre se encuentra la bola en la esquina superior derecha ,excepto cuando agito fuerte el movil hacia abajo colocando los botones hacia arriba, se mueve un poco la bola hacia el centro por la parte de arriba)
    Orientation Sensor  al agitar el dispositivo las burbujas se mueven ligeramente, aún así todas se mantienen fijas apuntando a la esquina inferior izquierda
    Gyroscope sensor El cuadro colorido se mueve ligeramente
    Varias aplicaciones dan lecturas registran datos similares, no logro calibrar el sensor
    He hecho los ¨ochos en el aire¨ y rotar el terminal por sus 3 ejes.
    He tratado de calibrar el sensor mediante varias apps que ¨prometen¨calibrar los sensores, sin resultados.

    He realizado las pruebas con:
    Android y sistema actualizado al ultimo update de ambos; con el dispositivo tal y como lo tenía; restaurado de fábrica; rooteado; con la ROM Lineage OS (versión estable) y volviendo a la Stock.


    ¿Hay alguna manera REAL de calibrar dicho sensor o arreglarlo? ¿directo a SAT?
    Estoy convencido de que el fallo es del acelerómetro, pero dudo mucho que sea un fallo de hardware, no ha sufrido caidas ni golpes o cualquier tipo de daño, pero tras probar con varias combinaciones de software me hace dudar


    Gracias



  • Imagino que lo mas facil que es en Ajustes, pantalla y girar pantalla, o en los accesos rapidos, lo tendras activado, por descartar



  • Imagino que lo mas facil que es en Ajustes, pantalla y girar pantalla, o en los accesos rapidos, lo tendras activado, por descartar
    Está activado (fue lo primerisimo que hice) pero recalco que el acelerómetro detecta en los ejes X,Y una aceleración bastante alta estando el teléfono sobre una mesa sin tocarlo


  • Buenos días:


    @titohuete Si actualmente tienes la última versión del firmware oficial instalada (4.5.0) , puedes probar accediendo al test de acelerometro y giroscopio desde el menú de diagnóstico que puedes ver marcando *#87# en el marcador del teléfono y entrando después al apartado "Hand Test".

    Al realizar el test "Accelerator" debes ver las 4 flechas que apunta en cada dirección. De no ser así, prueba a mover el dispositivo haciendo círculos en el aire. Al realizar el test "Gyroscope" comprueba si puedes ver todas las caras del cubo.

    Un saludo,



  • Buenos días:

    @titohuete Si actualmente tienes la última versión del firmware oficial instalada (4.5.0) , puedes probar accediendo al test de acelerometro y giroscopio desde el menú de diagnóstico que puedes ver marcando *#87# en el marcador del teléfono y entrando después al apartado "Hand Test".

    Al realizar el test "Accelerator" debes ver las 4 flechas que apunta en cada dirección. De no ser así, prueba a mover el dispositivo haciendo círculos en el aire. Al realizar el test "Gyroscope" comprueba si puedes ver todas las caras del cubo.

    Un saludo,

    Al terminar de meter el código, es decir, al pulsar el 2do # el código se borra


  • Buenos días:

    @titohuete Si actualmente tienes la última versión del firmware oficial instalada (4.5.0) , puedes probar accediendo al test de acelerometro y giroscopio desde el menú de diagnóstico que puedes ver marcando *#87# en el marcador del teléfono y entrando después al apartado "Hand Test".

    Al realizar el test "Accelerator" debes ver las 4 flechas que apunta en cada dirección. De no ser así, prueba a mover el dispositivo haciendo círculos en el aire. Al realizar el test "Gyroscope" comprueba si puedes ver todas las caras del cubo.

    Un saludo,

    Al terminar de meter el código, es decir, al pulsar el 2do # el código se borra
    ACTUALIZO INFO: He logrado entrar en el menú; adjunto foto de lo que se ve estando en una superficie plana

    https://drive.google.com/file/d/0B1i2jj7AVT3rMlRXamVSNDFRZUk/view?usp=drivesdk



  • @GMartinez en el giroscopio puedo ver todas las caras del cubo; sin embago el acelerómetro sale lo mencionado arriba



  • Buenos días:

    @titohuete Si no te aparecen las cuatro flechas al realizar el test, puede encontrarse el acelerómetro descalibrado o bien tratarse de un fallo físico.

    Para tratar de solucionarlo y descartar cualquier posible fallo del sistema o conflicto de las apps instaladas, puedes probar restableciendo a valores de fábrica desde Ajustes>Copia de seguridad, desmarcando "Copiar datos".Este proceso elimina el contenido del terminal, por lo que te recomendamos guardar los datos que desees previamente. Puedes hacer una copia de seguridad de los datos que quieras con estas indicaciones.

    Si el problema persiste, seria conveniente que te pongas en contacto con nuestros técnicos a través del siguiente enlace https://www.bq.com/es/support para que te informen una solución alternativa.

    Un saludo,



  • Buenas tardes.

    Tengo un Aquarix X Pro. Este venía con el acelerómetro bastante descalibrado. He conseguido una calibración HW correcta usando el menú del operador.

    Los síntomas son exclusivamente del acelerómetro. No hay que calibrar brújula ni el giróscopo. Con cualquier aplicación, la lectura del acelerómetro mostraba una desviación grande. Con el móvil perfectamente horizontal se mostraba: X=0.020 Y=1.0 Z=9,8 m*s^-2. Por tanto, otro sensor como el de orientación, marcaba un error de 4º en pich.

    Alguna aplicación de nivel permite realizar calibración, pero solamente es local para la aplicación. Además, era posible calibrar la horizontal sobre un eje, pero se perdía sobre otro.

    La solución fue:
    - Acceder al menú del operador. Depende del modelo. Consultad el foro o pedir a soporte que os den instrucciones. En el caso de aquaris X Pro, consiste en marcar en la pantalla de teléfono *#*#1111#*#*

    ***Cuidado al manejar este menu****

    - Entrar en el test de acelerómetro.

    - Poner el movil en horizontal

    - Presionar botón calibrar

    A partir de entonces desapareció la desviación.

    Un saludo,

    DCarras