Instalar TWRP - Problema Hard Reset



  • Buenas al foro.


    Estoy intentando instalar TWRP, paso previo para intentar rootear la tablet.

    Instalo los drivers Hard Reset... Lo he hecho tanto en un PC con Windows 10 como en otro con Windows 7

    La instalación de los drivers para Hard Reset termina con exito.

    Para terminar la instalación, conecto la tablet apagada al USB y la enciendo... pero me da a mi que no acaba correctamente la instalación de los controladores.

    Con el programa flash tools, intento instalar el recovery.img que lleva el TWRP, pero nada.

    Me sale una ventana con el mensaje: "TMP changed for the ROM; it must be downloaded"

    He desinstalado drivers, vuelto a instalar... pero no consigo instalar el recovery.img modificado con el TWRP.

    Imagino que ser cuestión de drivers incorrectamente instalados... Pero no se si existe opción de borrar... Me temo que puede haber algún conflicto con drivers de otros dispositivos con chip MTK que también he rooteado.

    ¿Alguna sugerencia?

    Otro método para instalar TWRP???

    Para instalar posteriormente Supersu me parece que tengo que modificar el boot.img y también flashear con la herramienta flash tools... O sea que me temo que no me queda otra que conseguir que funcione correctamente la herramienta. Mas si por el motivo que sea, tuviera que reinstalar firmware.

    Sugerencias serán bienvenidas. 

    Gracias.



  • Hola, ¿has probado con la opción Firmware upgrade? NUNCA uses FORMAT ALL.



  • No he probado con la opción de firmware upgrade ya que mi intención es flashear solo el recovery.img para instalar TWRP.
    Hay obligatorio flashearlo entero????


    Los manuales que veo para flashear TWRP recovery, todos dicen de flashear solo recovery.img con la opción download.... 

    Cuando se cambia a otra opción, automáticamente se marcan todas las casillas de verificación para flashearlo todo... Y claro, no es lo que pretendo.

    Lo he intentado con dos PC's uno con Windows 10 y otro Windows 7, borrando drivers e reinstalandolos de nuevo, tanto con instalador como de forma manual... Con depuración USB habilitado y sin habilitar.... Ya no se me ocurre nada mas.

    Si sigue así, espero no tener nunca la necesidad de flashear el firmware, ya que hoy por hoy, la tablet se está negando a dejarse flashear nada.

    No se si alguien de soporte de BQ me podría aconsejar acerca de este tema.

    Salud y saludos.



  • No, no es necesario el flasheo entero. ¿Estás en la versión 2.2.0?



  • Actualmente estoy en la versión 2.2.0.

    He probado flashear con la versión de firmware 2.2.0 y también he probado con la versión de firmware anterior, la 2.1.0. Me da el mismo mensaje de error.
    No, no es necesario el flasheo entero. ¿Estás en la versión 2.2.0?


  • Hola, lo voy a probar para descartar si es por la versión de Android o hay algo más :-).

    Si tardo mucho dame un toque.



  • Hola, probado en M10 FHD 2.2.0, Windows 10.

    • Tableta apagada y con buena carga de batería.

    • Firmware y drivers descargados desde bq.com en su última versión.

    • Abrir el flash tool en modo administrador > seleccionar Download only y el scatter de la carpeta del firmware.

    • Una vez cargado desmarcar todas las casillas excepto la de recovery, en Location de la casilla del recovery pinchamos y buscamos donde tengamos el TWR 3.0.0....img

    • Le damos a Download, esperamos que haga su trabajo (10-30 segundos) y ya habrá acabado, desconectamos del USB del PC 

      - Arrancamos con Subir volumen y encendido a la vez y ya nos sale el TWRP.

    • Si queremos hacer root ya seguir las instrucciones:


    y para recibir OTA's:



  • Esos pasos ya los he hecho, también ejecutando flash tools como administrador...

    El archivo.img del Twrp lo renombro como recovery.img y reemplazo el del firmware. Todo está en la misma carpeta del firmware..

    Doy a download, y conecto la tablet apagada al PC..

    Un par de sonidos en el PC que detecta que algo se ha conectado al USB...

    La línea roja apenas tarda un par de segundos al 100%

    Y sale este mensaje..

    "TMP changed for the ROM; it must be downloaded"

    Las herramientas y drivers descargado de la web BQ.com, de la zona de descargas del dispositivo Aquaris M10 FHD (el mío), y las herramientas y drivers son comunes para todas las M10.

    No será cosa de un problema de drivers que no quedan instalados correctamente?

    También he probado diferentes cables, el original de la tablet y otros, diferentes puertos USB.

    En fin... Ya no se que hacer. Espero no tener nunca la necesidad de reinstalar firmware por que con las herramientas que descargo de BQ, no me está funcionando.

    ¿Que versión de firmware tienes instalada? Tienes drivers de otros dispositivos Android?

    Mi anterior tablet, la E10, también con chip Mediatek la flashee en su día sin problemas. No entiendo por qué está se resiste.

    Saludos.



  • Hola, es la 2.2.0, la última disponible.

    Sobre si tengo otros drivers además de las M10 instalados, si, del M5.5 y de la Edison 3 mini (qualcomm e Intel)

    Para verificar si es tema de drivers puedes hacer un hard reset, si, se que es una "solución" algo "violenta" pero creo que no van por ahí los tiros.

    Voy a probar con una M10 HD para ver un detallejo que me mosquea y comento de nuevo 😉



  • Hola Raul.

    Descartado el tema de los drivers.... Acabo de hacer un hard reset e instalado la ultima versión de firmware y se la ha tragado.

    ¿Es posible hacer el firmware upgrade cambiando el recovery.img original por el recovery.img modificado con el TWRP?

    ¿O es posible que se produzca un error al detectar el intruso? 🙂



  • Hola, he probado en una M10 HD también en su última versión y no he tenido pegas, el TWRP se ha cargado correctamente.


    Edito: estábamos escribiendo a la vez 😛 , pues eso que comentas la verdad que no tiene porque ocasionar pegas, pero nunca lo he hecho y si lo he hecho fue en un E4 o E6, no recuerdo bien.

    La única pega que le veo es que al hacer el HR el sistema tarda bastante en arrancar hasta que ajusta todo en su sitio y es posible que le haga un barrido al recovery para cerciorarse que es el stock, no sé....

    Déjame probar @MANSER y vamos sobre seguro 😉



  • Hard Reset hecho cambiando el recovery:


    - Fuerzo el cambio de recovery al TWRP y ha entrado y cargado bien.
    - Reboot System desde TWRP y tableta arrancada con total normalidad ;).

    Por lo tanto si, se puede hacer, en mi caso también he desmarcado userdata 😛 , la tableta la usa bastante el niño y cuando se levante mañana le puede dar un soponcio se no ve sus jueguecillos :)) .



  • Mañana me pongo...
    ¿Sería conveniente modificar también el boot.img para que se trague el Supersu y flashear ambos a la vez con el hard reset?

    Imagino que si...

    Gracias, saludos y buenas noches.



  • Hola, no, no es necesario modificar nada más, ya siguiendo las instrucciones del hilo para el root y el tema de la partición system no habría que tocar nada más 🙂



  • Buenos días.
    Con la última versión de firmware el metodo de rooteo sería este:

    1º Descomprimir en cualquier lado. Del firm original coger el boot.img e introducir en la carpeta en la que hemos descomprimido dicho programa, el cual consta de 3 archivos: "bootimg.exe", "repack.bat" y "unpack.bat".
    2º Arrastrar con el ratón boot.img encima de unpack.bat, se nos crearan unos archivos y una carpeta.
    3º Lo único que hay que tocar es el archivo "cpiolist.txt" dentro del cual hay que borrar 2 lineas:
    -mode:mtk
    -mtk_header_name:ROOTFS
    4º Ejecutar repack.bat, se crearán dos boot.img, cogemos el que dice "boot-new.img" y lo renombramos a boot.img

    5º Flashearlo con MTK Flash Tool en "download only" no se borra nada.

    6º Podéis comprobar que arranca sino, algún paso se hizo mal, aunque siempre se puede volver a instalar el boot.img original.


    Como ves, el punto cinco hay que flashear con el MTK Flash Tool en "download only" que es el que a mi me toca las narices todo el rato.

    De ahí mi duda...

    ¿Que opinas? ¿Flasheo todo también con el boot.img modificado?

    Gracias.
     
    Anarion dijo:
    Hola, no, no es necesario modificar nada más, ya siguiendo las instrucciones del hilo para el root y el tema de la partición system no habría que tocar nada más 🙂


  • Hola, no había visto el nuevo método, es verdad que hay casos que el super su no lo coge en la nueva versión.

    Tendria que mirarlo más detenidamente.



  • Hola Anarion.

    Problema resuelto... Parece que el reinstalar el último firmware ha solucionado el problema que tenía con la utilidad flash tools.

    Ahora ya me deja flashear solamente el recovery.img o el boot.img con la opción "download only" y que antes me daba el maldito error.

    Algo diferente debía tener el firmware que me actualizó la tablet desde la OTA al que posteriormente flashee por completo con la utilidad flash tools...

    De forma indirecta, flashear el firmware de nuevo el firmware completo ha solucionado mi problema.

    Esta mañana me dejó flashear el nuevo recovery.. modifiqué el boot.img para que me deje instalar el zip del supersu.

    Ya tengo la tablet rooteada y completamente operativa con mis aplicaciones "preferidas"

    Gracias por tus indicaciones. Si no me hubieras dicho de flashear todo de nuevo para descartar el problema de los drivers... aún estaría dándole vueltas al tema.

    Espero que esta "batallita" le sirva a otros con mi misma incidencia y si lo desean puedan rootear la tablet.

    Salud y saludos.



  • Hola, gracias a ti por todo, y estoy contigo en que algo había en el firmware y el HR lo solucionó.

    Sobre el método de root me lo apunto, la información que aportas es muy valiosa. Muchísimas gracias.


  •