Problema con el homing del eje Y



  • Buenas a todos chicos, aquí un novato que acaba de montar su primera impresora.


    Después de bastante tiempo soñando con hacerme con una de estas, por fin decidí comprarme una e introducirme en este mundillo. Tras bastantes horas de montaje y estudio (sarna con gusto no pica), termino de montarla y llega el gran momento de probar mi nuevo juguete.... y me encuentro con que el homing no se hace de la manera en que esperaba. Mi problema es el siguiente:

    Cuando desde el LCD de mi impresora escojo la opción de hacer auto home, el eje X se desplaza de manera correcta y pulsa dos veces, todo correcto, pero el eje Y se desplaza en sentido del final de carrera y al tocarlo no retrocede para hacer un segundo contacto, sino que se atora y queda apretando el final de carrera... después de esto se hace el homing del eje Z sin problema. 

    Después de hacer este homing, se que está mal el eje Y, porque a parte de haber chocado en su momento, si decido mover el eje Y de manera independiente este solo se mueve en dirección hacia el final de carrera.

    He comprobado muy detenidamente la electrónica y el cableado, he comprobado que los finales de carrera están correctamente colocados en los pines del min., he sustituido el fin de carrera del eje Y por otro y pasa lo mismo, he cambiado el motor por otro, comprobado el calibrado de los drivers, comprobado que nada choca con nada, he probado con distintas versiones del firmware... 

    Ya no se me ocurre que mas hacer y por el foro he encontrado problemas similares pero ninguna de las soluciones encontradas se adecua a mi caso... ¿Alguien ha tenido un problema parecido y podría decirme que hacer?

    Muchísimas gracias de antemano!!


  • MVP

    Es raro lo que te pasa. Has probado de engañar con el dedo al hacer el homing para ver si gira en sentido contrario?
    Has probado de mover el motor desde el menú? va fino?



  • Puede que hayas conectado el conector del final de carrera del eje Y en el signo positivo en vez del negativo, comprueba la conexion del final de carrera y que está conectado donde está el signo "-"

    EDIT: Perdón, no terminé de leer y no vi que habias comprobado eso... de momento ni idea... si le das con el dedo antes de que llegue, ¿se para el carro?



  • Buenas chicos, muchas gracias por contestar. Efectivamente he probado a parar el carro con el dedo cuando hago el homing y si que se para, la cosa es que si luego intento mover el eje Y desde el menú sigue sin moverse en ambos sentidos, solo hacia el final de carrera como si el homing no se hubiera hecho.

    El movimiento es bastante fluido, de hecho al moverlo desde el menú puedo mover diferentes longitudes y parece que eso lo hace bastante bien, la cosa es que tanto se le digo que se mueva en positivo como si le digo que vaya hacia el cero siempre va hacia el final de carrera...


  • MVP

    Podría ser que tengas el cable mal conectado (los cables al conector, aunque es muy raro.

    Puedes decirnos como es el orden de los colores del cable en cada uno de los extremos?



  • Acabo de comprobar el orden de colores del conector, está primero el negro, rojo y amarillo. He comprobado que todos los negros estén a tierra y los rojos a la alimentación en los sensores así que no diría que estén mal.

    He intentado ponerme en contacto con el soporte de BQ pero aun no me han llamado...sigo a la espera a ver si doy con la clave y publico la solución al problema.


  • MVP

    Mira los cables del motor, que orden de colores, en los dos extremos. comprueba que el primero (oir ejemplo) sea el rosa en los dos lados, segundo e morado, etc, quiero decir que sean iguales los dos extremos, con el mismo orden-.



  • Los de los motores también los he comprobado y están iguales en ambos lados del conector... Llevo muchas horas (días) buscando los posibles errores y no he encontrado nada, así que me he puesto en contacto con el vendedor y me lo cambiarán por un kit nuevo por un posible fallo de la electrónica (supongo que del driver del motor y). A ver si con este nuevo kit tengo mejor suerte.
    Muchísimas gracias por la ayuda