[Resuelto]Cama Caliente 220v



  • Buenas a todos tengo una prusa i3 hephestos de bq, despues de mucho leer, me decidi a montar una cama caliente de 220v, ya que de todas formas había que montar un rele, y de esta manera me daba mas confianza usando un rele de estado solido. He aprovechado para montar el kit de cama larga de bq convirtiendo la Prusa i3 hephestos a Prusa i3 Hephestos XL.


    Lo he conectado todo, y cargado el firmware nuevo a traves de cmd con el make.cmd. Todo correcto, veo la temperatura de la cama caliente, y si pongo a imprimir algo y le marco que la temperatura de la cama caliente sea de 80 grados veo a la izquierda 25/80, pero hasta aquí puedo leer. no consigo que la salida D8 me de los 12 v. para que el relé de estado solido cierre el circuito de 220v. La cuestión es que me estoy fijando en el esquema, y creo que el conector verde (el del voltaje positivo negativo) en el esquema pone como que le entran 1 positivo y 1 negativo mas a la izquierda de los dos que ya tengo conectados con la fuente (no se si me explico), y creo que estos son los que alimentan el D8, estoy en lo cierto? si esto es asi, podria hacer un puente de los otros dos ya que el rele en estado solido necesita una intensidad mínima para cerrar el circuito? Muchas Gracias.



  • Hola @{fagmartinez}

    (edito) -> Bienvenido.
    Muchas gracias por tu explicacion.
    Me resulta muy complejo hacerme una idea clara de lo que te refieres, y entiendo que te has esmerado y seguramente sea totalmente cierto. Pero no es claro.
            Si pudieras acompañar una foto, con las notas que has expuesto seria mas claro. Las conexiones no son complicadas, es bastante sencillo. Seguramente sea algún pequeño despiste pero el texto no es la mejor de las opciones.

    Saludos y gracias.



  • Muchisimas Gracias por responder @Ardurino. Te pongo el esquema tal y como lo tengo conectado, y luego un segundo esquema con el puente que te comentaba.



    P.D.: he intentado poner las fotos directamente, pero se ve que soy un negado. lo siento



  • Exacto es la opcion mas adecuada a tu caso (montaje/componentes).

    Gracias por publicar las imágenes que han sido muy claras.

    Un matiz en cuanto al circuito.
    Es habitual poner un diodo (donde alimentas el rele sea este de estado solido o electromecánico), como medida de seguridad. (intenta documentarte sobre valores concretos del diodo, es el mismo , observa algún montaje, kit)
    Un saludo.

    PD: Esta perfectamente publicado. Mi opinión acerca de como publicar fotos/vídeos es exactamente como lo has hecho, ya que hacerlo "bonito" provoca que muchos usuarios no puedan ver la foto.



  • OK, @Andurino, he leido lo del rele en Antiparalelo, para que absorva el residual. En principio creia que no era necesario, Pero si toda medida de seguridad es poca, asi que se lo pongo y no se hable mas. Muchisimas Gracias. Ahora el siguiente hito, es el autolevel con sensor capacitivo, eso si me da miedo. jejejeje.


    Un Saludo, y gracias de nuevo.



  • Una pregunta mas, es que acabo de hacer una prueba. y el Termistor deja de funcionar a unos 50º (deja de marcar temperatura) hasta que se enfria, a unos 35º. Os suena de que puede ser? el termistor es este





  • Cama Caliente

     

    No hago publicidad, es información que considero apropiada al caso 
     Saludos.

    PD: @{fagmartinez} . ¿Vives cerca de Madrid? Hay un usuario  @{Fastcuco}  que necesita una mano con la cama caliente (en tema anterior) . Quizás hubiera una casualidad...



  • Pues muchisimas Gracias de nuevo @Andurino 


    Ya he solucionado, lo de la cama caliente, se me habia roto una patilla dentro de la cinta termoretractil, y me ha tocado desmontar comprobar y soldar, y justo se ha roto la otra, asi que he vuelto a soldar y les he puesto termoretractil nueva. Como no me queda cinta Kapton le he puesto cinta americana, que tambien me aguanta bien la temperatura. a ver lo que dura.

    De nuevo muchisimas gracias, y revisare lo del sensor inductivo. Aunque el que tengo es capacitivo, que en principio detecta el cristal y no necesito papel de aluminio. supongo que sera lo mismo



  • Me vas a mandar a la porra @{Andurino} , y me lo merezco. Acabo de sacar una pieza con la cama caliente a 90º y perfecto todo, o bueno casi todo. Cuando acaba de imprimir, y termina. En vez de ponerse a 0º grados la segunda temperatura de la cama caliente (para asi dejar de calentar) se me mantiene en 90º y sigue calentando la cama y manteniendolos, o sea si llega a 90º se apaga la cama caliente, pero si baja a 89º vuelve a encenderse la cama caliente. Supongo que sera una opción del configuration.h que tendré que modificar. me podrias iluminar de nuevo?


    A lo que me comentabas, no vivo cerca de Madrid, soy de Granada. He leido el post del compañero de Madrid. pero ya te digo me pilla a 500km



  • :-)) ¿porque he de enviarte a la porra?
    Gracias porque evidentemente has leído lo que te he sugerido y parece que te esta resultado adecuado para tus circunstancias.


    Entiendo el problema que me manifiestas acerca del apagado de la cama y sinceramente salvo que quieras que se apague cuando finalice y no estés presente ... ¿cual es el problema? (pregunta retorica , no es necesaria respuesta 😉 )
    Veo que si hay que verlo, pero son de esas cosas que hay que ir a detalles concretos y no tengo un acceso directo a tu caso lamentablemente. Eso no significa que no intentes solucionar y que la comunidad o yo  te intente ayudar en la medida que sea posible en solventar alguna duda.

    A voz de pronto y teniendo en cuenta que solo tengo tu versión escrita que he interpretar (no es nada malo , es así no le des mas vueltas), tengo la impresión de que no has modificado algo en el firmware algún detalle tontaco.

    Muchas gracias por manifestar la intención de colaborar, pero evidentemente hay muchos kilómetros hasta Madrid , yo tengo también una distancia "similar" pero hacia arriba y a la izquierda de Madrid

    Respecto al sensor inductivo/capacito/normalmente cerrado /abierto -> no nos liemos funcionan todos de modo muy similar solo es un pequeño matiz técnico que no tiene una relevancia "grande" en principio. Y dicho eso me contradigo, si la tiene pero no el sentido de que funcione bien el montaje. Varia el modo de captar e interpretar la señal (no te líes con estos asuntos técnicos)

    No me lo tomes a mal , pero... lo del sensor hay temas ya abiertos o crea el tuyo propio, ya que este se trata de cama caliente a 220V, te he manifestado sobre el asunto del sensor, solo para indicarte no para hablar del asunto aqui[-X 

    Saludos.



  • @{Andurino} Jejejejejeje, no es mi intención desviar el tema, solo te lo había comentado que era mi siguiente hito, aquí uno va aprendiendo poco a poco, preguntando y dandose calamonazos. Sigo liado con encontrar la opción que me lo permita. He estado buscando, y comentan que es cosa del Gcode que el programa laminador hay que decirle que apague la cama caliente. En Cura 15.0x era facil, pero en el nuevo Cura, ya no viene la opcion de Gcode Start y Gcode End, y mira que eran utiles. Bueno sigo intentandolo.



  • Hola de nuevo :D:
    No dispongo de la versión de Cura a la que te refieres (nuevo cura ??)

    Si uso la 2.1.3 para Ubuntu 64 ;).

    Esa opcion .... no exactamente lo de gcode start/end si no lo de la cama esta en:

    Extensiones-> post procesing-> Modify Gcode (y una vez dentro) en => tweakATZ

    Espero que sea ese el problema y no otro de tipo fisico/configuracion del firmware

    Saludos.



  • Hola De Nuevo @{Andurino} a esa mismo me referia Cura 2.1.3 pero para Windows, He mirado el TweakATZ y lo que me indica es parar la base a una altura en mm. es interesante, ya que sabiendo la altura de la pieza se pone a su altura y se para sola. De todos modos, el Cura 2.1.3 no termina de cuadrarme, un ejemplo, hace poco necesitaba hacer una tirada de 49 piezas iguales, en cura 15.0x multiplicar objeto y listo el solo me las ponia, en cura 2.1.3 se quedaba pillado. Bueno sin desviar el tema, he puesto en el End.Gcode del Cura 15.0x esto en la segunda linea:


    M140 S0

    y listo, ya me apaga la cama caliente cuando acaba. Bueno dicho esto, darte las gracias de nuevo por toda la ayuda ya que sin ti me habria devanado los sesos, y este tema se puede cerrar. De nuevo Gracias.


  •