¿Por qué el A4.5 no soporta el API Camera2?



  • Hola 🙂


    Acabo de descubrir que el A4.5 no soporta el API Camera2, el que Google introdujo con Android L para permitir ajustes manuales de la cámara. ¿Es por una cuestión técnica o de software? O lo que es lo mismo: ¿lo añadireis en alguna actualización futura o no hay planes para eso?

    Supongo que añadir ese API no depende de vosotros sino de Mediatek y Google, pero por preguntar no pierdo nada 😄



  • Buenas tardes,


    @{DervishD} Actualmente no es compatible, es una limitación de software de la plaforma de Android One. No obstante, no se descarta que en futuro se incluya en esta plataforma :).

    Un saludo,



  • Muchas gracias por las explicaciones, @{AMolina} 🙂


    Tampoco es que vaya a usar el móvil como cámara de alta gama 😉 y con el API de cámara actual algo se puede hacer en condiciones de poca luz, pero sería interesante.

    Por lo que veo, pocos terminales en el mercado soportan Camera2 por completo (en modo FULL), y de hecho poquísimos lo soportan incluso en la versión 'LIMITED', no es que haya tenido mucho éxito por el momento, y eso que se introdujo en Lollipop.

    No es nada urgente. Me importa más que me arregleis lo de los auriculares para el firmware 2.5.0 que lo echo mucho de menos 😄 Es broma, ya sé que estáis trabajando en ello y que es cuestión de esperar un poco.



  • Buenas tardes, 


    @{DervishD} ¡De nada! Para eso estamos :). Aquí nos tenéis siempre que podamos echaros una mano y ayudaros a solventar dudas o incidencias.

    Un saludo,



  • Si soportase la API2 de Cámara mencionada, ¿se podría actualizar la cámara de Google a la ultima versión?

    La verdad es que la versión de Google Cámara que tiene es algo obsoleta y fea. La ultima versión tiene muchas mejoras, aunque no soportase cámara lenta y demás opciones, pero solo por la interfaz... A mi me resulta mucho mas intuitiva.

    Es una Gozada en el Nexus 6P, cuando vi que no se podia actualizar en el BQ me lleve un chasco.

    Saludos.



  • Buenos días,


    @{rdrenedo} No disponemos de dicha información al respecto, ya que al no estar soportada por nuestros dispositivos, lo desconocemos.

    Sentimos no poder darte más información.

    Un saludo,



  • Si, ya he buscado información, la ultima versión de Google Camera a partir de la V3.0 utiliza la API de Camera2. Mientras Andorid One no la soporte no funcionara... Una lastima.


    Gracias, saludos.



  • Sentimos las molestias @{rdrenedo}. 


    Cualquier otra consulta que te surja, ya sabes dónde estamos para intentar ayudarte en lo posible.

    Saludos,



  • rdrenedo dijo:
    Si, ya he buscado información, la ultima versión de Google Camera a partir de la V3.0 utiliza la API de Camera2. Mientras Andorid One no la soporte no funcionara... Una lastima.
    En el momento en que el terminal soporte Camera2 (y eso depende de muchos factores porque sin tener más información no sabría decirte si el problema está en los drivers del SoC, en algo del Android que lleva nuestro dispositivo, en limitaciones del hardware de la cámara, etc.) hay muchas mejores opciones que la aplicación de cámara de Google. El API no proporciona mejoras de interfaz, eso es algo que Google puede hacer usando el API antíguo, lo que proporciona es otro acceso al hardware a las aplicaciones, y Google no creo que te permita muchísimos ajustes manuales en la V3.0 de su app. Hay otras apps que te los permiten sin Camera2, pero están usando un interfaz que Google considera obsoleto... y que es el que está en la inmensa mayoría de los terminales de Android. Camera2 FULL está en un puñado de terminales (creo que ni está en algunos Nexus antiguos), Camera2 LIMITED hay algún modelo más pero no me consta que sean mayoría, y en el resto lo mejor que puedes aspirar es a Camera2 LEGACY, que es un "wrapper" sobre el antiguo API, y que, que yo sepa, no usa ningún terminal.

    Ya veremos en el próximo MWC cuántos terminales anuncian que usan Camera2, porque algunos fabricantes han optado por usar su propio API para su aplicación de cámara, dejando el API obsoleto para el uso de las aplicaciones, con lo que no les veo implementando Camera2. A nosotros no nos debería ocurrir eso, puesto que esto es un Android puro, pero eso no significa que veamos Camera2 en el A4.5 dependiendo de si el problema es hardware, software o del SoC.


  • Si yo con que se pudiese usar la ultima versión de Google Camera 3.2 iba contento, me gusta mucho mas la interfaz y no necesito mucho mas para disparar 4 fotos. A ver si en futuras versiones lo implementan...


    Gracias por la información, saludos.



  • Hola, ¿con Nougat podremos catar la api de cámara 2 o seguiremos igual?