Problema con arduino



  • Hola, hoy vengo con un nuevo problema a ver si alguien me puede echar un cable. Cuando cargo el firmware con arduino la pantalla de mi impresora se queda en blanco. Sólo vuelve en sí cuando cargo el firmware oficial con cura. He majado el marlin de nuevo y he intentado cargarlo sin modificar nada por lo que descarto que sea problema de modificaciones.


    Esta es la configuración que tengo: 
    - Arduino/genuino mega or mega 2560
    - Procesador Atmega 2560
    - Programador AVRISP mkII
    - Puerto COM3

    mi impresora es una hephestos 2. Saludos



  • Hola pozuelo,


    Es normal, actualmente se sigue trabajando en el firmware (por el momento no es posible cargarlo con Arduino IDE), por lo que, para cargarlo correctamente, hay que usar Cura.



  • La hepestos 2 no lleva arduino, tiene una electrónica propia que no disipa calor, por lo que recomendamos que no se instale otro firmware. 

    Un saludo


  • MVP

    A ver si se libera pronto y podemos echarle un ojo a sus tripas.




  • El firmware de la Hephestos se compila a través de un make. En Github podéis encontrar tanto el firmware como la documentación para poder compilarlo. No es posible compilarlo con Arduino IDE debido a ciertas librerías. Pero el sistema de make es aun más fácil que el propio Arduino IDE.


    Toda la documentación de Hephestos 2 ya está liberada en el repositorio de Github, también su electrónica. 

    @{pozuelo}, por lo que comentas estás cargando el firmware original de Marlin. Ese código no está adaptado para la impresora Hephestos 2. Solo te va a funcionar el firmware creado para dicha impresora, ya que por ejemplo el código para el LCD ha sido creado solo para Hephestos 2 y Witbox 2.

    Para poner el firmware de Hephestos 2 puedes cargar el firmware desde el make o cargando el .hex desde Cura ;).



  • oks muchas gracias @{sgruben}, ya he descargado e instalado el make 3.81 pero al intentar abrirlo se abre una pequeña ventana negra que dura una milésima de segundo y se cierra. ¿Alguna idea de por qué me pasa? gracias



  • Abre el símbolo de sistemas y acude a la carpeta donde has descargado el firmware y ejecuta el make, escribiendo el nombre del archivo. Así la ventana no se cerrará y si salta algún error se podrá ver.



  • el archivo .exe si me deja ejecutarlo e instalar el programa, es cuando intento abrir el acceso directo en la carpeta C:\Program Files (x86)\GnuWin32\bin\make donde no me deja abrirlo.  Si meto esta ruta en el símbolo de sistema me dice "C:\ProgramFiles" no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable.