No se ven fotos en Galería (Cámara FV-5 - MicroSD)



  • Buenas.

    A ver si alguien me puede responder, porque resulta bastante incómodo. El error me da en Lollipop. En KitKat no me sucedía, pero quizá no tenga nada que ver con el Firmware, no tengo ni idea.

    El caso es que tengo instalada la app Cámara FV-5, y la tengo parametrizada para que guarde las fotos en la MicroSD. Pues bien: las fotos hechas con Cámara FV-5 (y con cualquier otra app de terceros) no se visualizan en la galería hasta que hago un reescaneado de multimedia (reiniciando el móvil o con alguna app de rescan).

    Con las fotos hechas con la cámara stock, que también guardo en la MicroSD, no hay ningún problema: se visualizan al instante. Sin embargo, si utilizo otras apps, las fotos no aparecen en Galería. Se crea correctamente el archivo, y yo puedo visualizarlo con ES Explorer; pero no veo las fotos en Galería hasta que fuerzo un reescaneado del multimedia. Es decir: parece que la cámara stock fuerza el rescaneado, pero otras apps de cámaras no lo fuerzan.

    ¿Alguien más con el mismo problema? Ya digo que en KitKat todo me funcionaba normalmente. ¿Alguna idea?

    Gracias y saludos.


  • MVP

    Debes de reiniciar la galería. Para ello vete a ajustes/aplicaciones/todas/almacenamiento de medios. Borra "datos" y reinicia el móvil.

    No perderás nada, tan sólo que al iniciarse tardará un rato en indexar, para mostrar las miniaturas.

    Después prueba a ver si ya visualizas todas las fotos que hagas con app externas.



  • Gracias por la respuesta.

    Ya lo probé, no funciona. Voy a listar todas las pruebas que ya he realizado:

    1.- Hacer un Wipe caché desde el Recovery - no funciona
    2.- Borrar caché y datos de Ajustes/Aplicaciones/Todas/Galería y reiniciar móvil - no funciona
    3.- Borrar caché y datos de Ajustes/Aplicaciones/Todas/Almacenamiento de medios y reiniciar el móvil - no funciona
    4.- Borrar caché y datos de Ajustes/Aplicaciones/Todas/Almacenamiento de medios, borrar valores por defecto, inhabilitar aplicación, reiniciar el móvil y volver a habilitar aplicación - no funciona
    5.- Cambiar la ruta de guardado de las fotos de Cámara FV5: si pongo la nueva ubicación dentro de la MicroSD (tarjeta externa), no funciona; si pongo la nueva ubicación dentro de la tarjeta interna, sí funciona

    Comentar que, al reiniciar el móvil, en la galería se muestran todas las fotos echas con Cámara FV5 que no se habían mostrado hasta entonces. Por eso, yo creía que el problema estaba en que no se forzaba el reescaneado de medios al hacer una foto con una app de cámara de terceros; de hecho, las fotos echas con la app de cámara stock las guardo también en la MicroSD y se muestran instantáneamente sin problemas.

    Sin embargo, lo que comento en el punto 5 (si pongo la nueva ubicación dentro de la tarjeta interna, sí funciona) me descoloca un poco. Por una parte, sé que la tarjeta externa MicroSD está bien porque la galería muestra las fotos de la cámara stock sin problemas; por otro, con Cámara FV5, la galería muestra bien las fotos si se guardan en la memoria interna, pero no si se guardan en la tarjeta externa; y para complicar más las cosas, con la misma tarjeta MicroSD, en KitKat funcionaba todo sin problemas.

    Y sí, la tarjeta está recién borrada, pero dentro del móvil. No sé cómo puedo formatearla en el PC, no tengo lector de tarjetas!!


  • MVP

    Si no tienes lector de tarjetas, no vas a poder hacerlo. Antes cuando se podía conectar la SD como almacenamiento masivo sí se podía formatear la SD conectando el móvil por cable al ordenador pero desde KK al conectarse el móvil por MTP ya no se puede. Siendo root creo que hay algo para conseguirlo pero mi consejo es que para eso ni te molestes.


    Si no te puede formatear alguien esa SD en FAT 32 desde PC yo te recomiendo que pruebes con otra. Ahora están de oferta las de 40 MB/s de velocidad de transferencia y clase 10 ( ya que han sacado las de 80 MB/s).

    Ayer en MediaMark he cogido una samsung clase 10 40mB/s de 16 GB por 5,5 euros (eso sí en Tenerife) y mueve vídeo y fotos perfectamente. Para que más?? bueno la de 32 GB de 40 mB/s valía 12 euros ( que no está nada mal). 

    Yo utilizo "A better camera" para fotos y "cinema FV-5" para vídeo en este terminal con L (5.0.2) y me muestra en la galería perfectamente las imágenes grabadas en la SD. Quizás por el problema que sea no te deja grabar en la SD el archivo que lleva el índice de indexación y las miniaturas, por lo tanto por eso no las ves en la galería. Debes de hacer lo comentado para descartar otros problemas, creo yo. Es lo más fácil y tampoco sale muy caro. Si después te sigue sin ir pues habrá que pensar en otra cosa.






  • Donde estoy ahora no hay lugar donde comprar y comprobar... a ver la semana que viene.

    La mala suerte es que no pueda formatear la tarjeta que ya tengo... La tarjeta venía con un adaptador a SD, con eso podría formatearla, pero el adaptador está más perdido que Adán el día de la madre...

    Lo extrañísimo es que las fotos sácadas con la cámara stock se vean instantáneamente en la galería, cuando se guardan también en la MicroSD. O las propias fotos de Cámara FV-5: si entro en ES Explorer y renombro la carpeta donde guarda las fotos, instantáneamente se ven en la galería! No hace falta ni copiar la carpeta ni cortar y pegar, basta con renombrar la carpeta y todas las fotos que no se veían hasta entonces, zas, aparecen en la galería...

    El error debe de estar en algo parecido a lo que mencionas:

    "Quizás por el problema que sea no te deja grabar en la SD el archivo que
    lleva el índice de indexación y las miniaturas, por lo tanto por eso no
    las ves en la galería."

    Yo creo que no se ejecuta correctamente el escaneado de medios tras sacar la foto... escaneado que se realiza correctamente con sencillamente renombrar la tarjeta donde se guardan las fotos!

    Con Cinema FV5 tengo exactamente el mismo problema. Voy a probar con "A better camera" a ver si sucede lo mismo... vale, con "A better camera" me funciona correctamente. ¿Problema de las apps de FV5, entonces? Curiosísimo que a ti te funcione bien (con Cinema FV5) y a mí no...

    A ver si me convences: ¿por qué utilizas "A better camera"?, ¿es mejor que Cámara FV5?


  • MVP

    Jaja...convencer ?? :-))    voy a intentarlo.


    La explicación es muy simple : A better cámera es totalmente gratuita,  tanto en foto como en vídeo sin limitación de calidad y encima da muy buena calidad en los dos casos. Para foto es bastante configurable aunque para vídeo no.

    Yo soy una persona que no me cuesta  pagar si no encuentro algo que sea bueno gratis. Yo pruebo muchas app y no me puedo permitir el lujo de pagar por todas.

    Sin embrago en vídeo utilizo cinema FV-5 Lite. Yo grabo siempre en HD en lugar de FHD. Esto ya es muy particular y complejo de explicar. El caso es que subiendo el bitrate y con codec h.264 o bajando el bitrate y con codec MPG4 se consigue buena calidad de vídeo `para ver en el móvil y en TV y ocupando mucho menos espacio.

    Yo antes utilizaba LG Camera para vídeos pero la optimización que han hecho últimamente en cinema FV-5 la hace mi predilecta.

    La explicación de por qué una app te muestre  bien las fotos de la SD en la galería y otras no, pues puede ser lo explicado anteriormente del indice de indexación y miniaturas. Es probable que después de formatear te dejen  todas o tal vez tengas que cambiar de SD. 

    En vídeo se complica aún más el tema pues puede influir  también la resolución, el codec, el bitrate y la propia velocidad de escritura de la SD.

    Con Cinema FV5 prueba a grabar a 720p codec h.264 y 17 Mbits de bitrate ( aunque con 12 Mbits se verá bien y ocupará menos). A ver si no te da problemas en la galería.






  • Bajado "A better camera"! Me la vendiste! Hay algún detalle muy interesante, como lo de aplicar enfoque y exposición en dos áreas distintas de la foto... se puede hacer con Cámara FV5, pero es mucho menos intuitivo. Me gusta!

    Y nada. Probé lo que me comentaste del codec y el bitrate y el error continúa. Por curiosidad, y abusando de tu amabilidad: ¿qué parámetros utilizas tú en Cinema FV5 de codificador y bitrate? ¿Prefieres h264 o MPG4? Yo utilizo la cámara stock para vídeo en 720p, y Cinema FV5 para 1080p, pero nunca me he puesto a jugar con los ajustes...

    Muchas gracias por todo!


  • MVP

    Jaja, soy un vendedor muy bueno...!! sobre todo a coste cero.:)

    Configuraciones de vídeo ideales??? Cada maestrillo tiene su librillo....

    No puedo explicar en unas líneas un minitutorial de vídeo. Sólo decir una cosa: en vídeo no lo es todo la resolución: HD o FHD. Influyen otros factores como son códec, bitrate y fps.

    Yo grabo normalmente en 720p con h.264 a 12Mbits y con 30 fps.

    A veces también grabo en 1080p con MPEG 4 a 12 Mbits y 25 fps.

    Resumiendo ( que ya me vale a mí, intentar resumir esto): Deben de estar en armonía todos los parámetros para conseguir buenos resultados pero que no se vaya mucho de tamaño el vídeo y que se pueda ver en la mayoría de los reproductores.

    h.264 comprime más que MPEG 4 y por eso hay que jugar con bitrate, resolución y fps. Hay quien mantiene los fps y baja el bitrate. A mi en FHD me gusta mantener el bitrate y bajar los fotogramas de 30 ( standard americano) a 25 ( standard europeo).

    La gente sube resolución y bitrate sin sentido dando vídeos de tamaño descomunal que para manejarlos en un smartphone ....pues en fin....

    Por último, a mi me gusta decir siempre, que en vídeo todo vale mientras se vea. Claro y se vea bien...jaja.

    Salu2 desde tapatalk



  • Muchas gracias por la explicación valle2305! Así da gusto!


  • MVP

    De nada...!! 🙂

    Salu2 desde tapatalk