Pantalla LCD no entra en modo "menu"



  • Hola, después de haber terminado hoy mi Prusa i3 todo parecia correcto. Al conectarla por primera vez siempre sale el ERROR: MINTEMP. No hay cables pisados ni comunicados.  Calentando la pieza con un secador,si que sube la temperatura!!. He actualizado el firm a través del arduino (marlin_hephestos) y ahora lo que pasa es que la pantalla se queda en la configuracion inicial, es decir, salen los datos de temperatura, xyz, sd, tiempo y el error de MINTEMP, pero al pulsar el dial para entrar a los menus retorna rapidamente al menu inicial y no deja entrar.

    Alguna solución a este problema?

    Muchas gracias, David


  • MVP

    Bienvenido, @multicoptero,


    Tomando como inicio que no has instalado ningún firm a la placa, ni actualizado ni nada:
    El error MINTEMP en Marlin es cuando detecta una temperatura por debajo de lo que considera "normal" por lo que entiende que hay un error en la sonda.
    Revisa bien las conexiones del termistor.
    Si te sale MINTEMP, ya no sacas el error hasta que reinicies, o sea que si solucionas el problema, pero no reinicias, la pantalla te seguirá dando ese error y no te permite hacer nada.

    Si has actualizado o algo, puede ser que hayas puesto un firm con la base calefactada activada.

    Seguro que es un problema sencillo de solucionar, ánimo!



  • Gracias Lucky,

    Si que he actualizado el firm. desde el Arduino, el problema principal es que la pantalla queda clavada. Es decir,  queda en el munú principal y cuando pulsas el dia hace un piip muy flojito y se queda toda azul medio segundo y retorna a su posicion original. No me deja correr por el menú. He revisado que la versión de pantalla fuese la correcta y si que lo es.

    No tengo ni idea!! 

    Otra cosita, los archivos con extensión HEX como los instalais?? En esto estoy de novato total!!
    Me refiero a los archivos que he bajado de la pagina de BQ .

    Gracias por vuestro tiempo,

    Saludos, David


  • MVP

    Para instalarlos usas el cura, en actualizar firm.

    Podría ser que hayas puesto uno preparado para mesa calefactada.
    Pon el original desde Cura y prueba.
    Revisa las conexiones.
    Si aparece MINTEMP en pantalla, de allí no lo sacarás hasta que lo soluciones, no te deja tocar ni menús ni imprimir



  • Hay que tener en cuenta que el botón que hay que pulsar es el encoder del LCD, el que es alargado y plateado. El botón negro es para una parada de emergencia.


    Yo estoy con lucky, carga el firmware original y revisa el termistor que esté bien conectado. 



  • Buenas de nuevo.

    Ahora ya me funciona la pantalla!! Ya puedo moverme por el menú sin problemas. He actualizado a través de Cura (15.04).  Lo que no logro es sacar el error de MINTEMP.

    Al tener ese error no puedo cargar filamento porque la máquina no sube grados.

    He revisado el termistor y no hay cables en mal estado o sueltos. Entiendo que el termistor no tiene  -+ por lo que donde está conectado, en los dos pines más bajos de la regleta tal y como marca el manual de la bq, no tiene nada que ver si el rojo o el negro estén en la posición que estén.

    Puede ser que se haya roto el termistor??

    Gracias por vuestro tiempo.

    Saludos, DAVID



  • @multicoptero, ¿te llega a marcar grados o directamente te pone que la temperatura es 0?. El termistor no tiene polaridad. Revisa si lo has conectado en el sitio correcto en la placa.



  • Está conectado en el sitio correcto y la temperatura es 0º.

    Si le doy a cargar filamento, la temperatura se queda en 0º.



  • Hola:


    Me parece entender que as verificado que el problema no es el sensor de temperatura:

    Ya que has aplicado calor (de forma externa) y ¿desapareció el MINTEMP?

    Suponiendo que el termistor este correcto.

    - OPCION 1: (EL EXTRUSOR NO SE CALIENTA NADA O MUY POCO)
    Si no se calienta, verifica si le llega tensión y si le llega de modo adecuado (respetando la polaridad).
    Si se calienta pero te aparece el error, Verifica los valores de temperatura de tu sofware de control de la impresora (A mi me ocurrió algo parecido pero era por que no estaba bien conectado, tuve que reajustar las bornas en la regleta para hacer un buen contacto.)

    ¿Desde donde estas dando la instrucción para que se caliente el extrusor?

    - Opccion 1. (Los valores de temp estan el firmware )
    Calentar desde el LCD /mandar imprimir una pieza desde el sd
    Tocar el firmware es sinomino de perder la garantia
    Cambiar la version del firmware siempre y cuando sea oficial. matiene la garantia

    - Opcion 2. (Los valores de temp los controla un programa)
    Verifica que los valores estén correctos (Pueden aparecer el control de temperatura en mas de un lugar del programa con propósitos distintos, en alguna configuración debe estar a 0)


    Saludos



  • Pues no hay manera!!

    Ahora como ya he contado funciona la pantalla perfectamente, pero la maquina no calienta y sigue con el error MINTEMP.

    Cuando le doy a la función de calentar, con el tester he pinchado en la placa en los terminales del calentador y no da corriente.

    ¿Alguien podria pasarme por mail la versión que usa para la BQ PRUSA I3 para cargar desde Arduino o Cura?

    ¿Podria ser que si el termistor está roto no empieze a calentar poruqe tiene el error en pantalla?

    Y por último,

    Donde se puede comprar, en España, un termistor 100k pero ya con la rosquita de cobre? O siempre llevan la rosquita??  Uy, estoy pez....pero sigo luchando...

    Gracias a todos,

    David MAS


  • MVP

    La impresora no empieza a calentar si no es capaz de leer el termisor, lo hace por seguridad, para no calentar  a ciegas.

    En este enlace encontrarás los firms actualizados
    Si desconectas el termisor, con el tester lo puedes probar:

    Instrucciones

    1. 1

      Ajusta el multímetro en el modo de resistencia.

    2. 2

      Conecta los terminales del multímetro a los conductores sobre el termistor. No importa que conductor vaya a los terminales, la polaridad no es importante en esta prueba.

    3. 3

      Calienta el soldador. Calentar el termistor moviendo la punta del soldador caliente a la misma.

    4. 4

      Observa la lectura del multímetro mientras estés aplicando el calor. Un buen funcionamiento del termistor de coeficiente positivo de temperatura muestra un aumento suave y constante en la lectura de la resistencia del multímetro. Un buen funcionamiento del termistor de coeficiente de temperatura negativa muestran un descenso suave y constante en la lectura de la resistencia del multímetro.

    5. 5

      Busca señales de un termistor defectuoso. Una lectura constante que no cambia, una lectura de cero o una lectura de infinito son todos indicios de que el termistor debe ser reemplazado. El cambio en la lectura no será suave o no habrá ningún cambio.



  • Ok, vamos bién, No ha cambiado el valor del tester cuando se calienta, Es más el valor no varia de ninguna manera. Por lo tanto voy a cambiar la pieza.

    Se encuentra fácil online con la rosquita de latón?

    Gracias a todos.

    David


  • MVP

    Has probado desconectando el termisor y probando con el tester? solamente con el calor de los dedos debería fluctuar de valor.


    Si te pones en contacto con servicio técnico seguro que te pueden ayudar con la pieza de origen.



  • @{multicoptero} lo mejor es que te pongas en contacto con el servicio técnico para revisarlo.



  • Muchas gracias a todos por vuestro apoyo y paciencia. BQ me envió un nuevo termistor y todo solucionado.

    Gracias, David