Conexión VPN - FortiClient y OpenVPN



  • He intentado conectar con el M5 con varias VPNs y no he podido en ninguno de los casos.


    - Con la de mi trabajo, a través de FortiClient, VPNSSL, me da este error:

    "Error: Revoked by Adroid: REBOOT!"

    - Con la de mi casa, a través de OpenVPN, me da este otro error:

    "Problem creating TUN interface. Possibly the tun.ko kernel module is not loaded in your Android kernel"


    ¿Podéis confirmarme si el módulo tun.ko está presente en esta compilación de Android, o lo habéis eliminado?



  • He rooteado el teléfono siguiendo los pasos del foro, para poder probar el TUN.KO installer

    Este me dice que el modulo está precargado en el kernel

    Tambien he probado con DroidVPN, y me da el mismo error: Failed to enable TUN Socket

    Haciendo un diagnóstico en DroidVPN, me da este error:

    Testing VpnService API: failed
    Failed to testVPNServiceAPI()
    java.lang.SecurityException: Calling uid 10138 gave packageandroid which is owned by uid 1000

    ¿Podria ser un problema con el SELinux?

    He probado con el SELinuxModeChanger pero tampoco consigo avanzar



  • Nadie puede decirme nada?



  • Hice un hard reset para instalar la nueva versión, pq la OTA no me iba, ya que lo había rooteado, y el problema sigue produciéndose con la nueva versión.



  • Tengo el mismo problema que tu, desde que estoy probando roms en Loli. Imagino que será un problema de éste, y deseo que BQ pueda darle solución. Estoy en el programa beta para E5 4G.


    Un saludo.



  • Me alegro de encontrar a alguien que responda!

    He abierto un caso con Fortinet, y tras hacer diversas pruebas con ellos, me han comentado que es problema de la compilación de lolipop hecha por BQ, que en en Lolipop puro si funciona. Parece que se han eliminado módulos del kernel...



  • Me alegro de encontrar a alguien que responda!

    He abierto un caso con Fortinet, y tras hacer diversas pruebas con ellos, me han comentado que es problema de la compilación de lolipop hecha por BQ, que en en Lolipop puro si funciona. Parece que se han eliminado módulos del kernel...


    A mi y a otros compañeros nos pasa exáctamente lo mismo con el cliente VPN de Juniper, el JunOS secure client. 



  • Lo mismo me pasa a mi con el junos pulse o el secure pulse. Cuando intenta conectar por vpn inmediatamente se desconecta.

    Ya que se trata de un móvil con doble SIM mucha gente lo usará como teléfono de empresa+particular, y en un teléfono de empresa es muy común tener una VPN para poder hacer un remoto, descargarte documentos de la red, etc.

    Conozco a gente con un BQ E5 que si le funciona, pero es con una Jelly Bean o una Kit Kat.

    Por favor BQ, haced lo posible para solucionar esto.



  • La semana pasada abrí una incidencia con el soporte de BQ respecto a este asunto. Por desgracia parece que no entendieron bien mi respuesta, ya que a pesar de facilitarles la URL de este thread, me contestaron con temas completamente distintos que no tenían nada que ver con esto. He abierto un segundo caso añadiendo más detalles y preguntándoles expresamente si el módulo TUN.ko está cargado en el kernel de los M5.


    Yo en su día tuve un problema similar con un HTC y el problema era ese. Tuve que rootearlo para poder resolverlo.

    A ver que me dicen en este segundo caso que he abierto.



  • Buenas,


    Tenemos localizada esta incidencia, y esperamos poder solventarla en una próxima versión de FW.

    Un saludo



  • Rivero dijo:
    Buenas,

    Tenemos localizada esta incidencia, y esperamos poder solventarla en una próxima versión de FW.

    Un saludo

    Al fin buenas noticias!! 

    Si necesitáis hacer alguna prueba con un FW en beta, podéis contar conmigo. Gracias!!



  • Rivero dijo:
    Buenas,

    Tenemos localizada esta incidencia, y esperamos poder solventarla en una próxima versión de FW.

    Un saludo

    Esperandolo el nuevo FW, menos mal porque me había llevado un chasco terrible al no poder usar mi nuevo movil con la VPN.

    osropa tiene toda la razón, lo habitual es tener un dual sim para poder usarlo en el curro y no poder abrir VPN es un handicap muy gordo, es muy normal que las empresas cuiden la seguridad y las VPN se usan habitualmente.



  • Sí, es lo que me han comentado en el ticket que abrí con soporte. Buenas noticias por parte de BQ. Han respondido rápido y a ver si lo sacan pronto y redondean la faena.



  • Otro más por aquí con el mismo problema. Tras revisar la comunidad, abrir un ticket y algunas pruebas, me confirmaron que se trata de un fallo de FW que esperan corregir en la próxima actualización.

    El trato y rapidez en el servicio técnico ha sido estupendo, esperemos que sigan así y lo resuelvan pronto!



  • Bueno, pues ya hemos recibido un firmware nuevo pero no ha corregido el problema 😮
    Esperó que no nos hagan esperar mucho 😞



  • Uno mas con el mismo problema. A ver si sale pronto esa prometida actualizacion donde van a arreglar este fallo (y algunos mas que aun tiene este telefono desde que salio)



  • Otro más con el mismo problema. No consigo que Junos Pulse mantenga una VPN activa. Me compre el movil hace una semana. Tenia compañeros que tenian otros BQ anteriores y funcionaba sin problemas.... ..... pero error  de novato, se me paso mirar antes por el forum....  si lo llego a saber me espero a comprarlo.... a ver si hay suerte y bq lo trata con la urgencia adecuada... si no no puedo usarlo para el trabajo. 



  • Buenas, otro más al carro... Si alguien tiene novedades, por favor que comparta!.



  • Tengo el mismo problema con Surfeasy y opera Max.
    Ninguno de los dos puede establecer una conexión VPN.
    Creo que hay algo despistado en la gestión de el VPN en general.



  • Otro con el mismo problema (OpenVPN y M5). Por favor amigos de BQ, pónganse las pilas con este tema, no es de recibo que un terminal con capacidad y potencia más que suficientes tenga un fallo como este.