No recibo notificaciones con el teléfono en reposo (Solucionado)



  • No recibo las notificaciones de whatsapp cuando el movil esta bloqueado. Una vez que enciendo la pantalla, es cuando me aparecen las notificaciones.



  • Buenas noches:


    @Teresae11 ¿Sucede cuando el dispositivo está conectado a Wi-Fi, datos o en ambos casos?

    Saludos.



  • Me pasa lo mismo con ambas conexiones. Más con WiFi (estando en Usar WiFi siempre en suspensión), pero también alguna vez con 3G.



  • @recu_92 ¿Sólo ocurre con las notificaciones de Whatsapp o también con otras de apps distintas? ¿Sucede en una red Wi-Fi en concreto o en cualquiera a la que te conectes?


    Saludos.



  • ese fallo del retraso de las notificaciones  de Whatsapp y del correo electronico con la Wifi puesta,en reposo,y al desbloquear el movil llegan todas juntas,eso esta ,mas que reportado


  • MVP

    recu_92 wrote:
    Me pasa lo mismo con ambas conexiones. Más con WiFi (estando en Usar WiFi siempre en suspensión), pero también alguna vez con 3G.

    Ponlo en lugar de "siempre" en "sólo cuando está cargando" y te funcionará bien.

    Salu2



  • Buenas noches:


    @gato Efectivamente, es un fallo que se encuentra en estudio y que ocurre en algunos casos. No obstante, en ocasiones se producen por otras causas, como por ejemplo tener activa la casilla de "restringir conexiones automáticas", provocando que no lleguen las notificaciones cuando estamos conectados a datos móviles, o por utilizar aplicaciones que desactiven la sincronización con el fin de ahorrar batería.

    Por otro lado, hay veces que sólo se produce el retardo cuando estamos conectados a una red concreta. Por ello, toda información que nos pueda aportar nos servirá para intentar ayudarle, o en el caso de que no sea posible de manera inmediata, estudiar el comportamiento aun más y solucionarlo en futuras actualizaciones.

    Saludos.



  • sisi,,,,,lo comentaba para que el amigo recu no se preocupara y viera que nos pasa a algunos,solo era eso




  • sucede tanto en la conexión de datos como con el WiFi. Y no solo con el whatsapp, sino también con el correo y algunos juegos.



  • He hecho lo que dice valle 2305y de momento funciona. Muchas gracias


  • MVP

    Teresae11 wrote:
    sucede tanto en la conexión de datos como con el WiFi. Y no solo con el whatsapp, sino también con el correo y algunos juegos.
    Por lo que comentas esta relacionado con los servidores push y a todos los niveles no sólo con bloqueo en WiFi ( como el compañero anterior ) te recomiendo que hagas e instales la app push fix que recomienda el faq de whatsapp ( vale para push en general) y de paso que hagas lo que se recomienda para whatsapp propiamente dicho.

    http://www.whatsapp.com/faq/es/android/20887936

    Salu2


  • MVP

    Teresae11 wrote:
    He hecho lo que dice valle 2305y de momento funciona. Muchas gracias

    Si te falla en otro momento haz lo otro que te recomiendo pues lo del modo suspensión es para solucionar la incompatibilidad del chisept con ciertos router en modo suspensión WiFi.

    Ya nos contarás si das con la tecla . salu2



  • Hola

    A mi también me ha pasado esto, aunque a veces las notificaciones se retrasan 5 o 10 min. Pero lo de hoy ha sido curioso y os lo pongo por si pudieran ir por ahí los tiros.
    Enciendo el tfno, wifi activada. Como voy a salir de casa la desactivo para que no me gaste más batería de la cuenta pero noto que las notificaciones se retrasan mucho a no ser que tenga la pantalla encendida o estar dentro de whatsapp (ha habido una con un retraso de 30 min que ha llegado al activar pantalla). He mirado los procesos que tenía activos y he visto que estaba el WIFIP2P pese a tener la wifi desactivada. Este proceso se me ha debido de quedar activo porque tengo la aplicación Vodafone Wifi y es la que lo debe de haber "retenido". Ha sido detener ese proceso y voilà, han empezado a llegar perfectamente.
    Espero que sea de ayuda...


  • MVP

    LucasP wrote:
    Hola

    A mi también me ha pasado esto, aunque a veces las notificaciones se retrasan 5 o 10 min. Pero lo de hoy ha sido curioso y os lo pongo por si pudieran ir por ahí los tiros.
    Enciendo el tfno, wifi activada. Como voy a salir de casa la desactivo para que no me gaste más batería de la cuenta pero noto que las notificaciones se retrasan mucho a no ser que tenga la pantalla encendida o estar dentro de whatsapp (ha habido una con un retraso de 30 min que ha llegado al activar pantalla). He mirado los procesos que tenía activos y he visto que estaba el WIFIP2P pese a tener la wifi desactivada. Este proceso se me ha debido de quedar activo porque tengo la aplicación Vodafone Wifi y es la que lo debe de haber "retenido". Ha sido detener ese proceso y voilà, han empezado a llegar perfectamente.
    Espero que sea de ayuda...

    Para mí está claro que en tu caso sí , pero dependiendo de como tengas la suspensión WiFi establecida. Cuando un móvil tiene conflicto en deep sleep es que hay conflicto de app o de procesos.....o de chipset con determinados router. Hay que probar e ir descartando.

    ..................................................
    Se aprende: enseñando. Salu2



  • Yo tengo configurada la Wifi así:
    Wifi en suspensión --> Siempre
    Solo conexiones estables --> Desactivado
    Minimizar batería con wifi --> Desactivado

    En casa tengo Ono, pero el cablemodem que tengo es de los antiguos sin wifi. El router neutro que tengo enganchado para tener wifi es un Linksys


  • MVP

    El mismo caso que el tuyo lo tuvo mi mujer que monta un chipset de la misma marca que el tuyo y también de Vodafone pero sin la app wifi vodafone. A ella se lo causaba la aplicación de ahorro de energía de qualconn. En estos casos lo más fácil y lo que le recomendé a parte de desactivar el ahorro es que si vuelve a notar algo raro cuando esta con datos es que reinicie el móvil. Ella no tiene mucha idea y ya sabes...

    ..................................................
    Se aprende: enseñando. Salu2


  • MVP

    LucasP wrote:
    Yo tengo configurada la Wifi así:
    Wifi en suspensión --> Siempre
    Solo conexiones estables --> Desactivado
    Minimizar batería con wifi --> Desactivado

    En casa tengo Ono, pero el cablemodem que tengo es de los antiguos sin wifi. El router neutro que tengo enganchado para tener wifi es un Linksys

    Claro!!!....por eso te pasó pues el móvil entendía que estaba conectado a WiFi cuando tan sólo era su proceso. A ver no te quiero liar....a ver si le entiendes:

    El chipset de qualcomm cuando crea conflicto en deep sleep con ciertos router la única forma de que no lo haga es poniendo el modo suspensión en "solo cuando esta cargando" si lo tienes así y se te vuelve a quedar enganchado cuando pases a datos no te ocurrirá nada pues el móvil cuando esta en deep sleep lo has configurado para que no se conecte a WiFi.

    La optimización de WiFi la puedes tener activa o no depende de cada caso pero lo otro haz lo que te digo y te irá fenomenal.

    Me he explicado o te he liado más?

    ..................................................
    Se aprende: enseñando. Salu2


  • MVP

    El router aunque sea neutro te está dando problemas, creo yo.

    ..................................................
    Se aprende: enseñando. Salu2



  • valle2305 dijo:
    LucasP wrote:
    Yo tengo configurada la Wifi así:
    Wifi en suspensión --> Siempre
    Solo conexiones estables --> Desactivado
    Minimizar batería con wifi --> Desactivado

    En casa tengo Ono, pero el cablemodem que tengo es de los antiguos sin wifi. El router neutro que tengo enganchado para tener wifi es un Linksys
    Claro!!!....por eso te pasó pues el móvil entendía que estaba conectado a WiFi cuando tan sólo era su proceso. A ver no te quiero liar....a ver si le entiendes:

    El chipset de qualcomm cuando crea conflicto en deep sleep con ciertos router la única forma de que no lo haga es poniendo el modo suspensión en "solo cuando esta cargando" si lo tienes así y se te vuelve a quedar enganchado cuando pases a datos no te ocurrirá nada pues el móvil cuando esta en deep sleep lo has configurado para que no se conecte a WiFi.

    La optimización de WiFi la puedes tener activa o no depende de cada caso pero lo otro haz lo que te digo y te irá fenomenal.

    Me he explicado o te he liado más?

    ..................................................
    Se aprende: enseñando. Salu2

    Si, me he aclarado con el tema, gracias.
    Ahora me está pasando incluso sin tener nada de la wifi activado...... Voy a investigar a ver si alguna de las últimas aplicaciones que haya instalado están causandolo


  • Tras estar trasteando todo el fin de semana parece que ya funciona. He hecho lo que decía valle2305 y ha funcionado. Las notificaciones ya no llegan con el retardo de antes al estar solo la conexión de datos activa.
    También decir que he ido quitando aplicaciones que posiblemente me estuvieran causando el problema y creo que ya se cuales eran. Por un lado la que comenté de Vodafone WIFI. Tras esa el problema persistía, así que seguí con la de Mi fibra Ono y Wifi FTP. Alguna de ellas estaba provocandolo porque ahora ya me va perfecto.