Campus de Navidad BQ

Disfruta de una oferta especial por ser miembro de la comunidad en nuestros Campus BQ, más información aquí

Actualización 1.4 para Prusa i3 Hephestos


  • Administrador

    Acabamos de publicar la actualización de firmware 1.4 para tu impresora bq Prusa i3 Hephestos. En esta versión se incluyen las siguientes mejoras y correcciones:


    • Optimización de la navegación por la pantalla, mejor velocidad y respuesta general.
    • Mejora de compatibilidad con Repetier.
    • Optimización de la descarga de filamento.
    • Mejora del proceso de cambio de filamento durante la impresión.
    • Detección de archivos no válidos o corruptos.
    • Mejoras para el uso con base caliente.
    • Confirmación de seguridad de la parada de impresión.

    Para dicha impresora se han creado cuatro firmware, en los que se diferencia el idioma entre inglés y español, y que también se tiene en cuenta si se ha añadido el kit de ampliación de base para Prusa.

    En el siguiente enlace podrás descargar las cuatro versiones del firmware (español e inglés para base corta y base larga):


    Para actualizar tu impresora tendrás que conectarla por USB a un ordenador y usar el programa Cura para cargar el firmware. Puedes descargar aquí el tutorial detallado con todos los pasos a seguir. También puedes seguir las instrucciones de instalación que te mostramos en el siguiente vídeo.



  • Enhorabuena por todo lo que estáis creando!!


    Me gustaría saber si se ha incluido algo para que si se va la luz al volver a encender la prusa continúe donde lo dejó, ¿quizás pueda ser esa mejora de "Confirmación de seguridad de la parada de impresión"?

    Para hacer impresiones de más de 15 horas esa función es esencial para atreverse a hacerlas =D, tengo varias piezas grandes sin acabar por este problema =(, también para poder apagar la impresora y que no consuma y continuar estando delante al volver de un finde fuera jeje. Necesito hacer piezas de calidad que tardan más de 75 horas.

    Muchas gracias!



  • La confirmación de seguridad de la parada, es que tienes que pulsar dos veces para parar la impresión. Digamos que tienes que confirmar que lo quieres parar. En algunos casos nos equivocábamos y queríamos pausar la impresión en vez de pararla, entonces ya no había manera de retomarla. Ahora si lo quieres parar tienes que darle dos veces ;).


    Lamentablemente no es posible por el momento. Digamos que por el momento no tiene memoria donde almacenar el punto donde se encuentra. Entonces con tal que se apaga, es como si volviera a empezar de nuevo. ¿Has probado a poner un SAI para que aunque se vaya la luz la electrónica siga encendida?



  • Instalado y funcionando, ¡muchas gracias!


    Salseando en los menus me ha surgido una duda. ¿Es posible cambiar el orden en el que se muestran los archivos de la SD en el menú? Es decir, alfabético, carpetas primero y luego archivos, tamaño, fecha de creación...



  • Lamento postear dos veces seguidas, pero creo que he encontrado un problema con la actualización.


    Cuando configuro en cura una impresión con Fan speed a menos de 100% este no arranca en ningún momento de la impresión. Como si no hubiese habilitado el cooling fan.

    He probado con diferentes valores y parece que el resultado siempre es blanco o negro.

    Aquí dejo un gcode con (en teoría) Fan speed min 20% y max 40% por si sirve de ayuda.




  • Gracias por el reporte MementoMori, le echamos un vistazo y te digo.



  • Está ya subido en algún lado el código fuente para cargarlo en Arduino-IDE?





  • @MementoMori, ya hemos localizado el problema del ventilador de capa a distinta velocidad. En el archivo configuration.h hay una línea que tienes que descomentar. Es la línea #define FAN_SOFT_PWM, tienes que quitar las barras que están antes. En la próxima actualización lo añadiremos. Mientras quien lo quiera solventar puede descargarse el firmware de github que ya está solventado.



  • Me alegro de haber sido de ayuda y gracias por la solución.

    Aún no he probado a compilar el firmware, ahora tengo una excusa para aprender 🙂



  • Buena actualización, sobre todo en la navegación los por menús porque era un poco desesperante y ahora va perfecto.  

    He notado que ahora hay un retardo al mover los ejes manualmente desde el menú. No se si será intencionado o no pero antes no pasaba.
    Antes ordenaba los archivos de la sd por fecha de modificación pero ahora parece que no sigue ningún orden ¿hay forma de ordenarlo?

    Edito---

    Si que se sigue cierto orden de fecha en los archivos solo que aparecen mas abajo de los archivos que ya tenía en la sd.



  • Con 1.4XL no funciona el ventilador de capa.

    He probado con el mismo archivo y mismo perfil de cura.
    En 1.4 no se encienda. En 1.3.1 si.
    El firm es el último de github descargado ayer.
    A vosotros os funciona?



  • Desde hace unos días todas las piezas que imprimía salían mal hasta el punto de ser inservibles 



    Le he dado mil vuelta al asunto y me he dado cuenta de que es debido al ventilador de capa que no se enciende. Tengo el firm modificado en la linea FAN_SOFT_PWM y pongo en el Cura vel min. 100% y max 100% y no arranca de ninguna forma. 
    He vuelto a la versión 1.3.1 y funciona perfectamente, me he vuelto a bajar la 1.4 sin modificaciones con la linea FAN_SOFT_PWM arreglada y sigue sin arrancar haga lo que haga

    Me vuelvo a la 1.3.1 
    😞



  • Justo lo que me ha pasado a mi.

    Como he dicho antes, he actualizado a 1.4 y he hecho un cubo de calibración y salia muy mal.
    Todo era darle vueltas al cura y a la calibración y al final me he dado cuenta de que era el firmware 1.4.
    Bueno, Utopia, al menos ya sabemos cual es el problema.  😉
    Un saludo



  • Si estamos haciendo pruebas y vemos que la salida D9 no se llega activar. Estamos mirándolo para solventarlo lo antes posible. Mientras tanto podéis poner la versión 1.3.1 ;). Siento las molestias.



  • Podéis subir  la carpeta entera en zip , no solo el .hex ( lo digo para poder meter nuestras 

    calibraciones de ejes "x,y " y Pid , con el arduino  ) La tengo otra vez en ingles para poder tenerla calibrada ...

    Gracias , un saludo ! 

    😄



  • Puedes descargar el código de github. Para ponerlo en español solamente necesitas cambiar el valor de la variable LANGUAGE_CHOICE. El español es el 5.



  • Gracias ! 


    un saludo.



  • Hola.


    Ya se sabe algo al de porque no se activa la salida D9?



  • A ver , a mi si que me funciona y tengo la versión de marlin 1.4 . En un principio no me funcionaba , pero lo que hice fue cambiar esta linea :

     #define FAN_SOFT_PWM
    y le puse delante esto //
    // #define FAN_SOFT_PWM
    con lo cual esta constante queda anulada.
    Ademas esta salida la comparto con un laser montado en la parte trasera y funciona 100 %(laser de 500mw para corte y piro grabado). 
    Lo que no he investigado, es el por que ¿?.