Campus de Navidad BQ

Disfruta de una oferta especial por ser miembro de la comunidad en nuestros Campus BQ, más información aquí

Ligação VPN com 3g



  • Estou com grandes problemas a nivel profissional: utilizo bastante a ligação VPN para me ligar remotamente à empresa. O problema é que com wifi ligo-me sem problemas, mas com 3g a VPN não funciona (não liga). Isto acontece a mais alguém. Com o meu aquaris4.5 isto não acontecia, sempre consegui ligar a VPN em 3g. Alguém me pode ajudar?



  • Não uso VPN, por isso não te posso ajudar, parece que existem por aí problemas nessas ligações no 4.4.2:


    During the development of Android 4.4 KitKat, the time came to spruce up some of the lower-level pieces that are responsible for creating and managing VPN connections. As with any normal code rewrite, a few bugs crept into the mix. Unfortunately, some of these bugs proved to be relatively catastrophic to a lot of users, leaving them unable to conduct their business.
    Tunneling IPv6 over IPv4 simply doesn’t work. In other words, if you connect to a VPN over IPv4 and the other end supports IPv6, any IPv6 address you attempt to communicate with will be unreachable. Everything will appear to be connected and working, but those data packets simply won't leave your device.
    Changing connection types (e.g. from wifi to 3g) will result in a disconnection from the VPN. The disconnection might be intentional, as it could be a safety measure to prevent possible snooping. Reconnecting to the VPN is the bigger issue. Some people claim that they can reconnect over the new interface right away, some say that they can only reconnect over the original interface, and some people simply cannot reconnect over any type of interface without first rebooting. To be fair, there isn’t enough information to completely rule out specific apps or environmental conditions.
     
    Do que conheço do E4.5 só posso recomendar que vejas se tens em Definições/utilização de dados/menu alguma limitação de ligações automáticas.Considerava ainda a possibilidade de existir algum antivirus, etc que pudesse impedir a ligação, e falava com o administrador da rede para estudar outras possibilidades



  • Muito obrigado pela resposta e tentativa de ajuda, mas continuo sem vpn por 3g. No meu anterior smartphone (aquaris4.5) não tinha qualquer problema, e com o mesmo cartão!
    Toda a ajuda é bem vinda, começo a desesperar, porque preciso da vpn para trabalhar!



  • Boas, Nautico77,


    Estive a fazer uma pesquisa e infelizmente é um grande problema que se está a passar na versão do Android 4.4 Kit Kat muitos usuários já reportaram esse problema.

    Vou ver se encontro alguma solução e depois digo aqui. 🙂

    Cumps, 😄



  • @Nautico77, desculpa não ter respondido mais cedo. Podes me dar detalhes mais especificos sobre a 3G não conectar a VPN? 🙂

    Cumps, 😉



  • Olá AndroiderPT,
    Então é assim:

    • com wifi, ligo a VPN sem qualquer problema (ligação PPTP).
    • com 3g, tento ligar, fica a moer, até que aparece a mensagem de ligação sem sucesso (ou "sem ligação ", não me recordo bem qual é...)

    O problema não pode estar no lado dos servidores da empresa, pois com o meu aquaris4.5 não tinha problemas de ligação.

    Considero o E4.5 um equipamento bastante aceitável para utilização profissional (e por isso já convenci mais de uma dezena de colegas a adquirem smartphones bq), mas sem ligação VPN por 3g, as coisas ficam complicadas! Começo a ter a minha cabeça a prémio!



  • Boas, Nautico77,

    Vê a mensagem privada que te enviei.

    Cumps, 😉



  • Olá AndroiderPT, obrigado pela mensagem.
    Faço exatamente a mesma coisa que no video, mas, claro, com o meu user, password e endereço do servidor vpn da minha empresa. Corre tudo às mil maravilhas em wi-fi, mas se tiver em 3g, simplesmente não liga a VPN.

    Irei continuar a pesquisar sobre este problema. Queria evitar contatar diretamente o suporte da bq, pois já sei que vão pedir para fazer um hard reset,..., e acabarei por enviar o equipamento para lá, para nada ser resolvido, pois acontece o mesmo aos meus colegas que também usam a vpn.

    Muito obrigado



  • @Nautico77, não sei se o problema aqui seja com o Android 4.4 eu pesquisei e parece ser um "bug" no Android 4.4 muitos utilizadores do Android 4.4 mencionaram isso e outros não a 3G para a VPN funciona perfeitamente em alguns, por isso nem eu tenho bem a certeza.


    Mas já contactas-tes a tua operadora de rede, sobre isso? 😉

    Cumps, 😄



  • Podes também certificar-te se tens os APN certos para usar VPN, pode existir algum bloqueio por parte da operadora em algum tipo de APN, por isso é importante falares com eles ou veres no fórum deles, se existe, alguma queixa ou indicação



  • Não me lembrei disso! A ver se amanhã contato a Meo e a Vodafone. Mas acho estranho isto acontecer com ambas, ainda por cima já usava o s mesmos cartões no Aquaris4.5, e ligava a VPN sem problemas. Mas de qualquer forma vou contatá-los... Depois dou noticias. Obrigado pela ajuda.

    De qualquer forma, deixo aqui uma questão: no site da meo, explicam com configurar a apn para a internet. Na opção 'tipo de apn' devo ter 'internet', mas quando tento alterar, aparecem varias opções menos a opção internet. Alguem sabe o que selecionar? Neste momento tenho selecionado default e supl.



  • @Nautico77, envio-te uma mensagem em privado. 😉

    Cumps, 🙂



  • Peço desculpa de só agora responder, tive fora do país em trabalho.
    Contatei as operadoras Meo e Vodafone. Não há restrições a nível de VPN, e os APN estão bem definidos. Vou atualizar para o novo update que saiu ontem e testar. Se não resultar irei contatar o suporte bq.

    Irei atualizando este assunto.