Supercama caliente



  • Hola JAD: He descargado el archivo que me has pasado  "https://github.com/bq/Marlin/releases/tag/1.4.2" . Cuando lo abro observo que.  el archivo  "Arduino INO"  no aparece, en su alugar aparece "Marlin"    tipo de archivo "Arduino file" sin comillas. lo abrì para saber si pudiera abrirse normalmente y no aparece la pestaña "configuration h" se me hace todo muy raro, creo que tengo problemas con mi ordenador, hace cosas raras, esta circunstancia podría estar dificultando la correcta instalación de algunos archivos?



  • A ver @{dranelje} el archivo que tienes que abrir es el : Marlin.ino , los ficheros configuration.h y configuration_adv.h , estan en la carpeta config , y tienes que copiarlos a la carpeta donde esta el archivo marlin.ino , tendras hephestos y otra carpeta que pone hephestos_xl , en la segunda es para base larga y no esta esa variable.

    Pd: si tienes base larga copia los archivos de la cama corta y modifica las variables ancho y largo de la cama
    #define X_MAX_POS 200
    #define X_MIN_POS 0
    #define Y_MAX_POS 300
    #define Y_MIN_POS 0



  • Hola JAD:

     He instalado lo que me has indicado y efectivamente esta la variable // #define HEATED_BED_SUPPORT  y la "descomenté", pero...siempre hay un pero, la cama caliente sigue sin enterarse de que tiene que calentar, el problema no es la cama, pues he probado a conectarla directa de la fuente y calienta bien, será problema de la RAMPS?. Tampoco sale en pantalla la temperatura de la cama, pero cuando doy imprimir en la pantalla sale "calentando cama".  Realmente no se cuál será el problema, pero me fastidia pensar que he gastado un dinero para nada.
    Gracias por tu atención y perdona las molestias.
     Saludos
    dranelje



  • @{dranelje} 
    1 En el display aparece la temperatura de la cama ?
    2  Que programa usas para imprimir ? , si el laminador no le dice a la ramps que encienda la cama , esta no se enciende. Tendras que configurar el programa para que encienda la cama antes de empezar a imprimir.



  • JAD En el display no aparece la temperatura de la cama .El programa que uso para imprimir es el CURA



  • Pues @{dranelje}  ahi ya me has pillado, puedes hacer una foto al display de la impresora y ponerlo ?. Y tambien los cambios que has hecho en el marlin , por ver donde esta el fallo. Tambien podrias bajarte la version del marlin original y probar a ver si por lo menos aparece la temperatura de la cama en pantalla.
    https://github.com/MarlinFirmware/Marlin



  • JAD como te paso la foto de la pantalla LCD ?

    De todos modos te explico: en la pantalla aparece en la parte baja lo siguiente "calentando cama" pero no aparecen los grados. Parece que ordena calentar pero omite conectar la cama. Estoy pensando en resetear la ramps servirá para algo?
    Saludos
    .



  • Hola JAD:
    He instalado la versión marlin original y efectivamente sale lo que creo es relativo a la temperatura de la cama, está en la primera linea de la pantalla a la derecha de la temperatura del hotend, se ve un cuadradito blanco con una especie de H dentro (no se si es una h o un icono) y a su derecha  0/0º.

    Y ahora eramos pocos y ......el ordenador está hecho unos zorros, ya lleva tiempo pero ahora ya no detecta si está conectada la prusa, bien, el lunes toca llevarlo al taller, una semanita si poder trastear con la impresora.
    Saludos 



  • Hola @{dranelje} , correcto esa es la temperatura de la cama , ahora solamente te falta imprimir una pieza con cama caliente y ver que funciona.
    Pd en el marlin original , tendras una subcarpeta donde estara los ficheros configuration.h y configuration_adv.h , configurados para la hephestos:
    marlin /example_configurations/Hephestos/



  • Hola JAD:
    Con el marlin original en el que si se ve la temperatura de la cama, en la parte baja de la pantalla LCD sale lo siguiente:


    Error: MINTEMP BED

    Como se corrige esto?



  • Hola @{dranelje}  ese error se produce cuando no tienes conectado el terministor de la cama  a la ramps. Comprueba que esta bien conectado.



  • Hola JAD: 

    Efectivamente, el termistor no iba, lo he cambiado por otro y ahora en la pantalla LCD dice Hephestos lista. Pero ya no puedo hacer nada más pues el ordenador no conecta con la impresora, lo llevaré a reparar y luego a ver que pasa.
    Muchas gracias por tus consjos
    Saludos 



  • @{dranelje} Puedes imprimir mediante la tarjeta sd , por hacer una prueba. Indica al cura que utilizas cama caliente y ponle la temperatura que quieres que alcance.



  • Hola JAD:
    Inserté la sd y todo va sube temperatura de la cama y del hotend, pero cuando llega alas temperaturas consignadas no imprime



  • Bien @{dranelje} , ahi ya creo que debe de ser un problema de configuracion del programa laminador (cura) . Ya que por lo que me cuentas , las temperaturas alcanzan los valores que tu habias asignado. Ahora es cuestion de probar , lo mejor seria con el ordenador conectado . Podrias tambien probar con otro programa , MatterControl o Repetier.
    Mira tambien el tema del pid en la cama caliente , ya que hasta que el firware no consiga estabilizar la temperatura , no empezara ha imprimir . descomenta esta linea del marlin :
    //#define PIDTEMPBED y luego pruebas a ver.
    Para calibrar el pid una vez activado tendras que poner esto : M303 E-1 C8 S90 , 8 ciclos a 90 grados, esto te dara 3 resultados bedKp , bedKi y bedKd , que tendras que remplazarlos en el Marlin.
    Bueno , creo que te he mareado un poco, lo mejor es ir por pasos y si tienes alguna duda ya comentas.



  • JAD: He descomentado //#PIDTEMPBED, los parámetros que dices M303 E-1 C8 S90 , 8 ciclos a 90 grados, ya lo tiene puesto el marlin , estos son de temperatura? Se tiene que hacer en el Pronterface?




  • Si