Nuevos drivers FTDI para conexión USB


  • Administrador

    Acabamos de publicar los nuevos drivers FDTI_Modificados para bq Witbox, mejoran la compatibilidad de la conexión con tu ordenador.


    Puedes descargarlos desde aquí:


    Solamente necesitas descargarlo y proceder a la instalación. Si tienes tu bq Witbox conectada a tu ordenador, desconecta el cable USB y vuelve a conectarlo de nuevo.  En ese momento el sistema Windows detectará correctamente tu impresora asignando un puerto COM para la comunicación de datos.



  • Buenas noches,


    No hace demasiado que tengo la Witbox y por ahora he ido pasando los GCodes con la SD. Lo que no tengo claro es lo del USB, no consigo imprimir directamente desde el Cura por USB. Deduzco que no es capaz de imprimir directamente por cable verdad ?

    Necesito que me confirméis esto, ya que no he encontrado la respuesta concreta. Lo que si he hecho con el USB es actualizar el firmware (eso sin esta actualización que nos comentas). Creo que teniendo USB se debería poder imprimir directamente desde el software. Y entrarían otros factores como la posibilidad de poder imprimir desde una misma Red, sin la necesidad de estar al lado de la impresora físicamente.

    Muchas Gracias.



  • Se puede imprimir perfectamente por USB. Si usas Cura, sería necesario que seleccionaras el puerto COM correcto en las opciones de machine -> machine settings... y que la velocidad esté en 115200. Cuando esté seleccionado verás que el símbolo del disquete o SD cambia para que puedas imprimir por USB.


    Te recomiendo que uses la última versión de Cura 14.09, es la mas estable y ya incorpora la Witbox en los modelos predefinidos.


  • MVP

    Hola.
    Resulta que me ha pasado el famoso fti-gate, o sea, que al poner un pc con win8.1 64b, ha funcionado bien un rato y luego, ya no ha habido manera.
    Los drivers de win desconfiguran el PID de la placa arduino por usar un clon del fti.
    Logro usarla, se como poner otra vez el PID de fti a 6001 pero cada vez que pongo el win8.1, me lo resetea.
    Hay alguna manera de que no pase? no encuentro para que windows no quiera actualizar drivers.
    La impresora ha de ir cambiando de pc y es un engorro



  • Dejando el valor en 6001, pon los driver de FTDI, para ver si te sigue pasando esto. 



  • lucky dijo:
    Hola. Resulta que me ha pasado el famoso fti-gate, o sea, que al poner un pc con win8.1 64b, ha funcionado bien un rato y luego, ya no ha habido manera. Los drivers de win desconfiguran el PID de la placa arduino por usar un clon del fti. Logro usarla, se como poner otra vez el PID de fti a 6001 pero cada vez que pongo el win8.1, me lo resetea. Hay alguna manera de que no pase? no encuentro para que windows no quiera actualizar drivers. La impresora ha de ir cambiando de pc y es un engorro

    Hola,

    a mí me ha pasado lo mismo al conectar un pc con windows 10. Conseguí que se conectara e imprimiera conectado con USB con Cura pero al día siguiente no había manera de que se conectara de nuevo.

    El problema es que utilizamos varias personas la impresora y ahora los que utilizan mac no se les conecta tampoco, cuando antes no tenían ningún problema.

    No sé si será el problema de que se ha desconfigurado el PID después de haber conectado mi ordenador pero no sé como restablecer los valores de antes. No encuentro el valor de 6001 del que habláis.

    Si no es problema de que se ha desconfigurado, ¿cuál podría ser el motivo para que no se conecte ningún ordenador ahora?


  • Banned

    Buenas tardes, @{javierfv}:


    Puedes probar a instalar los drivers FTDI, para ver si te sigue pasando esto desinstalando los que ya tengamos instalados.

    También podrías probar a conectar la impresora a diferentes puertos y con diferentes cables.

    Un saludo,




  • Buenas tardes,

    Tengo una duda acerca de los drivers, la impresora monta una placa arduino Mega y una shield ramps (lo normal en una impresora).

    ¿por que el ordenador no la reconoce como arduino Mega normal y corriente para cargar un firmware?

    Un slaudo


  • MVP

    La ramps usa un integrado que convierte el puerto USB a datos serie, que luego se comunica con el integrado principal.

    Los drivers son para el primero, pero una política algo bestia de FTDI hizo unos drivers que si dudaban de la originalidad del chip (de su marca), automaticamente le cambiaba unos datos de este y los drivers dejaban de funcionar.
    Es el pequeño que hay arriba a la izquieda.
    En windows no detecta el arduino como tal, normalmente lo detecta como FT232R USB UART, o USB.02-Serial (CH340) 



  • Hola
    La placa que monta la witbox no es exactamente la que has puesto.. La que has puesto es un clon arduino mega 2560 con chip CH340, las que montan son unas Freeduino con chip FTDI que para nada sirve con los driver anteriores.

    Y por supuesto, la ramps no usa NINGUN tipo de "integrado que pasa a serie" la ramps es solo una shield para tener los pines necesarios bien ordenados y conectar los cables.

    Mi duda (ya la he revuelto) es por que se han complicado con una plata tan particular en lugar de usar una con chip ch340..

    Un saludo