Campus de Navidad BQ

Disfruta de una oferta especial por ser miembro de la comunidad en nuestros Campus BQ, más información aquí

Bq en Ubuntu 14.04



  • Hace unos días conecté mi Aquaris E5 FHD a mi portatil con Ubuntu 14.04, como dispositivo MTP y funcionó muy bien. Logré acceder a las carpetas de la tarjeta SD interna y la SD externa. Ayer lo volví a intentar pero no lograba reconocerlo más que como dispositivo PTP. Corrí los siguientes comandos en el terminal del ordenador:

    sudo apt-get install libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9
    sudo apt-get install mtpfs

    Pero seguía sin funcionar. Después conecté el cable en un puerto usb del otro lado del portatil (usb 3.0) y descubrí que Ubuntu reconocía de nuevo el dispositivo en modo MTP.
    Confiado en que ese era el problema (conectar el cable en el puerto adecuado) corrí los comandos:

    sudo apt-get remove libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9
    sudo apt-get remove mtpfs

    Después de eso el movil dejó de ser reconocido, tanto como en modo PTP como en MTP. Volví a correr los comandos iniciales, pero no funcionó. Ahora simplemente no lo reconoce y no se como solucionarlo.



  • Hace unos días conecté mi Aquaris E5 FHD a mi portatil con Ubuntu 14.04, como dispositivo MTP y funcionó muy bien. Logré acceder a las carpetas de la tarjeta SD interna y la SD externa. Ayer lo volví a intentar pero no lograba reconocerlo más que como dispositivo PTP. Corrí los siguientes comandos en el terminal del ordenador:
    sudo apt-get install libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9
    sudo apt-get install mtpfs

    Pero seguía sin funcionar. Después conecté el cable en un puerto usb del otro lado del portatil (usb 3.0) y descubrí que Ubuntu reconocía de nuevo el dispositivo en modo MTP.
    Confiado en que ese era el problema (conectar el cable en el puerto adecuado) corrí los comandos:

    sudo apt-get remove libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9
    sudo apt-get remove mtpfs

    Después de eso el movil dejó de ser reconocido, tanto como en modo PTP como en MTP. Volví a correr los comandos iniciales, pero no funcionó. Ahora simplemente no lo reconoce y no se como solucionarlo.

    Cuando has puestos los comandos remove ,¿ sabes lo que estabas haciendo? ,yo creo que no, si te paras y los miras ,veras que has desinstalado las librerias  MTP.

    Dicho esto ,ya sabrás cual es la solucion ¿no?

  • MVP

    Con Ubuntu 14.04 funciona directamente el MTP sin instalar nada extra. Para reinstalar lo que has eliminado instala el metapaquete ubuntu-desktop:

    sudo apt-get install ubuntu-desktop

    El comando es válido para Ubuntu 14.04 con Unity. Si usas otro escritorio es diferente.



  • Ya he corrido
    sudo apt-get install ubuntu-desktop


    y además volví a correr 

    sudo apt-get install libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9
    sudo apt-get install mtpfs

    Pero sigue sin detectar el movil, ni siquiera en modo PTP, cosa que si hacía antes.


  • MVP

    Usa el Live CD / Live USB y comprueba si te funciona MTP. Con esa prueba sabrás si es un problema de configuración del Ubuntu que tienes instalado o es un problema de configuración del teléfono.



  • A mi me funciona perfectamente en los dos modos en Ubuntu 14.04,  y no he tenido que hacer nada especial.
    Además mi ordenador es algo vejete, no tiene USB 3.0 y sin problema.
    No se si esto te ayudara pero en Synaptic, en buscar, he introducido "mtp" sin comillas claro y esta es la salida de paquetes instalados.

    libcurl3
    libcurl3-gnutls
    gvfs-backends
    libmtp-common
    libmtp-runtime
    libmtp9
    libnet-smtp-ssl-perl

    No se si esto te pondrá en alguna pista útil.
    Saludos



  •               Hola JMRiveroFernandez,<br><br>A mi me ocurre lo mismo, estoy en Linux Mint Cinnamon, me he dado cuenta de que esto sucede cuando abro la aplicación de música "Banshee", entonces, el móvil deja de ser reconocido, y bien tengo que reiniciar el móvil, bien tengo que reiniciar el pc, sino el móvil no vuelve a ser reconocido (misterios de la informática). Así pues, fíjate si te sucede lo mismo que a mi. Cuando yo conecto el móvil sin tener abierto banshee (ni abrirlo mientras estoy haciendo transferencias de archivos al móvil o viceversa), si que me lo reconoce directamente y sin ningún problema. Es una pena, pues pasar la música directamente desde Banshee es mucho más fácil... pero bueno.<br>


  • No sé si lo llegaste a arreglar, pero aquí te dejo mi receta. Al menos es cómo lo tengo configurado en mi equipo (y funciona correctamente):


    Paquetes:

    redstar@oczstar:~$ dpkg -l | grep mtp | cut -d " " -f 3
    libmtp-common
    libmtp-dev:amd64
    libmtp-runtime
    libmtp9:amd64
    libnet-smtp-ssl-perl
    mtp-tools
    mtpfs

    Dejando de lado el paquete de perl y el de desarrollo que han sido capturados de más, debes teclear:

    sudo apt-get install libmtp-common libmtp-runtime libmtp9 mtp-tools mtpfs

    Con eso deberá haberse creado (y deberás modificar) el archivo /lib/udev/rules.d/69-libmtp.rules, con esta nueva línea (antes o después del resto de dispositivos, pero nunca al principio o al final):

    # BQ Aquaris E5 FHD 2a47:0c02
    ATTR{idVendor}=="2a47", SYMLINK+="libmtp-%k", MODE="660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

    La primera línea es un comentario, puedes omitirla, pero la segunda línea debe estar toda junta a ser posible.

    Si quieres usar adb o desarrollar aplicaciones en android necesitarás, además, modificar el archivo /etc/udev/rules.d/51-android.rules:

    #BQ
    SUBSYSTEM=="usb", ATTR{idVendor}=="2a47", MODE="0664", GROUP="plugdev"

    Al igual que antes debería estar la segunda línea completa y no dividida en dos.

    Tras eso reinicia udev:

    sudo /etc/init.d/udev restart

    Inmediatamente debería aparecer el móvil. Si no lo hace comprueba que tienes descomentada la siguiente línea de /etc/fuse.conf:

    # Allow non-root users to specify the allow_other or allow_root mount options.
    user_allow_other

    Creo que no queda más por comprobar. Dime si te funciona, a otra persona que tuvo nuestro mismo problema se lo arreglé con esas modificaciones (espero que no se me olvide ninguna).

    Un saludo.



  • Excelente solución para este terminal, en Ubuntu 14.04.

    Me refiero a la que da RadStar, me ha funcionado a la primera.
    para los que comienzan en Ubuntu deben escribir en el terminal:

    sudo gedit etc /lib/udev/rules.d/69-libmtp.rules

    Y seguir las instrucciones que da el comapañero RedStart

    Gracias y saludos


  • MVP

    @apex22 hay que tener un poco de cuidado con sudo y las aplicaciones gráficas. Usa alternativas como gksudo o similares. En algunas ocasiones, al usar sudo de esa forma se pueden quedar mal los permisos y dar problemas al iniciar la sesión de Ubuntu.

    Más información: http://www.kubuntu-es.org/wiki/sistema/por-que-se-debe-usar-kdesu-o-kdesudo-ejecutar-aplicaciones-graficas-terminal-vez-usar-s



  • La ayuda que habeis puesto es correcta, pero la sintaxis esta mal!!! [Corrijo] el foro la pone mal.. ejjeje


    [Editado] Efectivamente el foro se come caracteres

    La sintaxis del  //lib/udev/rules.d/51-android.rules

    es la siguiente:

    SUBSYSTEM=="usb",ATTR_LLAVE_idVendor_LLAVE_=="2a47",ATTR_LLAVE_idProduct_LLAVE_=="0c02|7f10",SYMLINK+="android_fastboot"

    Es decir, los idVendor e idProduct que hay a continuacion de ATTR van encerrados entre llaves. El foro no me las reconoce, por eso he escrito LLAVE. Colocad una llave de apertura y otra de cierre que engloben a idVendor, idProduct reemplazando los lugares donde yo he escrito LLAVE

    Similarmente, en el fichero 69-libmtp.rules, ambas palabras van encerradas entre llaves.

    era por eso por lo q no funcionaba mi Aquaris X5 en adb .

    Por cierto, el id de producto del Aquaris X5 es el 7f10. Podeis ver el id de vuestro BQ escribiendo en consola:

    lsusb

    Vereis que aparecen todos los perifericos usb que tengais conectados, y entre ellos sale el BQ con el identificador 2a47:7f10

    Gracias por vuestra ayuda!!