Ligar ecrã após chamada



  • Olá. Durante a chamada o ecrã desliga-se para poupar energia e impedir o acionamento indevido de ordens com a face. Até aqui tudo bem, em modelos anteriores podíamos escolher se queríamos que isto acontecesse ou não, não encontro essa opção neste software.

    O problema é que após terminar a chamada demora uns (parecem longos) segundos a retomar o ecrã. Há forma de reduzir o lag? Penso que ou é do sensor de proximidade ou de erros de software que demoram a dar a ordem para se ligar.
    Alguém tem este problema? e como se resolve?



  • Vou responder a mim mesmo, adiantando uma pista, o protector de ecrã não tapa o sensor de proximidade, nem a camera frontal



  • qashqool dijo:
    Vou responder a mim mesmo, adiantando uma pista, o protector de ecrã não tapa o sensor de proximidade, nem a camera frontal
    Gostei da tua auto-resposta.

    Normalmente os problemas que indicas são pelo protector de ecrã. Mas, normalmente quando há esses problemas, o telefone nem volta ao ecrã principal (apenas quando desligam a chamada).

    Para que não bloqueie o ecrã tens duas opções: mãos-livres ou colocar o altifalante. Em relação ao "lag" que afirmas, poderá ter relação com base nas aplicações que tenhas em segundo plano.

    Experimentei e demora 1/2 segundos. Parece-me normal.

    Cumprimentos,


  • o meu caso demora cerca de 4 a 5 segundos, já tive ocasiões em que não chegou a retomar o ecã, Tive que usar o botã Power.

    Não me está a apetecer nada fazer um hard reset, e o backup CWM já tem algum tempo, muita coisa aconteceu depois 🙂
    Mas se tem que ser....paciência
    [EDIT] o sensor de proximidade é aquela janela oval ao lado da camera frontal, certo?




  • Normalmente os problemas que indicas são pelo protector de ecrã. Mas, normalmente quando há esses problemas, o telefone nem volta ao ecrã principal (apenas quando desligam a chamada).

    Para que não bloqueie o ecrã tens duas opções: mãos-livres ou colocar o altifalante. Em relação ao "lag" que afirmas, poderá ter relação com base nas aplicações que tenhas em segundo plano.

    Experimentei e demora 1/2 segundos. Parece-me normal.

    Cumprimentos,

    Olá mingo, uma dúvida, que o manual do telefone não explica, o sensor de proximidade é a janela oval ao lado da camera frontal? ou pode estar escondido dentro da parte branca? è que o protector de ecrã deixa essa janela livre e tapa o resto. Porque fiz um restore do CWM e o problema mantém-se. A única hipótese que tinha era o Xposed ou o Gravity terem alterado parametros, mas o backup que tinha era anterior a isto


  • Boas,


    Sim. O sensor é aquela parte negra pequenina rectangular, ao lado da câmara frontal. O Xposed não permite alterar essa configuração. 

    Podes sempre apagar a chamada com o botão "power" - DEFINIÇÕES > ACCESSIBILIDADE.

    Vou verificar se de alguma forma, com root, podemos alterar esses parâmetros.

    Cumprimentos,



  • Para já, fiz um hard reset, mais root e CWM e parece que ficou tudo bem, excepto a trabalheira que tive.:(|)

    Estava com medo que fosse algum problema de hardware, porque estava-se a agravar e, no final, quando fazia uma chamada desligava-se logo o ecrã, mesmo sem o aproximar da cara.
    Penso que a haver alteração de parâmetros só pode ter sido do gravity, ou de alguma das suas funcionalidades.
    o autor afastou essa hipótese, mas sabemos que quando se mexe em equilíbrios, sem querer altera-se alguma coisa que não se devia.
    Depois de recuperar desta canseira, (uns dias  :D) vou regressar ao xposed, talvez opte por outros módulos antes do gravity



  •    boa noite a todos!

       Estive a lêr todos os vossos comentários em relação a este problema de "ligar ecrã após chamada". Desde há algúns dias, quando faço ou recebo alguma chamada, o ecrã desliga totalmente. É uma situação bastante chata porque, de facto, por vezes, não quero atender a chamada ou simplesmente só desejo dar um toque. Acontece também que, para poder "controlar" a chamada (desligar) tenho de carregar no botão do power.
       Tenho estado a lêr os vossos comentários anteriores e estou completamente perdido porque não percebo nada de tecnologias ... falam de hard resert, backup CWM, Xposed, Gravity ... não percebo nada disto!!! 😞
       Alguém poderia dizer-me, passo a passo, como fazer para solucionar este incomodativo problema, por favor? acham que se poderá resolver facilmente ou é um problema do tfno e o terei de trocar? ...

       agradeço os vossos comentários e orientações,



  • frankikos dijo:
       boa noite a todos!

       Estive a lêr todos os vossos comentários em relação a este problema de "ligar ecrã após chamada". Desde há algúns dias, quando faço ou recebo alguma chamada, o ecrã desliga totalmente. É uma situação bastante chata porque, de facto, por vezes, não quero atender a chamada ou simplesmente só desejo dar um toque. Acontece também que, para poder "controlar" a chamada (desligar) tenho de carregar no botão do power.
       Tenho estado a lêr os vossos comentários anteriores e estou completamente perdido porque não percebo nada de tecnologias ... falam de hard resert, backup CWM, Xposed, Gravity ... não percebo nada disto!!! 😞
       Alguém poderia dizer-me, passo a passo, como fazer para solucionar este incomodativo problema, por favor? acham que se poderá resolver facilmente ou é um problema do tfno e o terei de trocar? ...

       agradeço os vossos comentários e orientações,

    Bom dia 🙂

    Não te preocupes, já que é difícil para qualquer pessoa.

    Para que te possas orientar um pouco mais, vê isto:


    --------


    Em relação ao sensor, por favor verifica o seguinte:
    1- Se tens algum protector de ecrã que esteja em contacto com o sensor de proximidade;
    2- Se tens alguma capa protectora que interfira com o sensor.

    Se a resposta for negativa, faz um restabelecimento de fábrica:
    DEFINIÇÕES > COPIA DE SEGURANÇA E REPOSIÇÃO > REPOSIÇÃO DADOS DE FÁBRICA.

    Se o problema persistir o que podes fazer é:
    DEFINIÇÕES > ACESSIBILIDADE > BOTÃO LIGAR/DESL...

    Cumprimentos


  • Aqui o nosso amigo mIngogomes podia fazer um tutorial em português, adaptando ao A5  os tutos que existem neste forum  :bz



  • qashqool dijo:
    Aqui o nosso amigo mIngogomes podia fazer um tutorial em português, adaptando ao A5  os tutos que existem neste forum  :bz
    Boas!

    Jaja, não haveria nenhum problema. O que sucede, é que como moderador apenas temos de dar suporte ao firmware oficial de bq. TvCastro é um usuário que não é moderador, pelo que não existe problema nenhum em fazer isso.

    Eu faço aqueles que os usuários pedirem, mas não nos responsabilizamos por qualquer problema que possa advir pela realização de tais procedimentos.

    Se quiseres algum, basta pedir: por privado ou directamente em um Post 😉

    Cumprimentos.


  • iste problema nenhum em fazer isso.
    Se quiseres algum, basta pedir: por privado ou directamente em um Post 😉

    Feito  ^:)^