Fallo giroscopio



  • Cuando uso el móvil, por ejemplo YouTube o geometry dash, al salir, el giroscopio no responde, para que funcione bien tengo que ir a ajustes/accesibilidad/girar contenido al girar la pantalla/ a alguien más le pasa?



  • Buenas @{GJAndroid}


    Te refieres a la opcion "Girar automaticamente"?

    La tengo activada siempre, y despues de usar Youtube, esta opcion se me mantiene asi. (La coloque en la cortina para tenerla mas a la vista.)

    Has comprobado que el giroscopio funciona correctamente cuando esta activo?

    Si el giroscopio "funciona", entonces el problema seria que se desactiva la opcion de "girar automaticamente" de repente, lo he entendido bien?



  • Sí, sería algo así, aunque muestra que está activado, y cuando funciona bien, si que gira todo perfectamente



  • Pues llevas por aqui un tiempo 😛


    ...asi que sera mejor que empieces comentando que es lo que has probado para remediarlo, para no estar repitiendote cosas que ya has hecho.

    Asi de primeras , haria un wipe de cache..  y un buen reinicio. :-?
    Lo que no se es si se pierde algo importante haciendo solo la limpieza de la cache, creo que no, pero no estoy seguro del todo.



  • He probado reiniciándolo, y funciona, pero si desactivo y activo el giroscopio desde ajustes de pantalla sigue sin ir, tengo que ir a accesibilidad, como ya había dicho antes



  • Tienes algun Launcher instalado?



  • No



  • Esto te ha pasado hace poco cierto?


    Seria bastante util en estos momentos que hagas mucha memoria, y recuerdes que fue lo ultimo que hicistes con el movil antes de que empezara a suceder esto.

    Te lo digo porque parece cosa de software, el giroscopio puede descalibrarse, incluso quedarse pillado (por el foro hablaban de ello, con solucion rapida incluida) pero esto de "a veces si, a veces no", no lo veo propio de un problema de hardware a menos que hayan accidentes de por medio.

    Mi consejo es que le des vueltas al coco, porque si en un par de intentos mas no lo enderezas, ya te imaginas lo que toca hacer. Un restablecimiento de fabrica para comprobar que funcione bien en un entorno "limpio".

    Lo siento porque no se me ocurre nada mas... 😞
    Quizas mañana algun compañero viene con la clave, espera un poco a ver.

    Saludos.



  • Me pasa desde hace bastante tiempo, casi tanto como lo del parpadeo de la pantalla


  • Administrador

    Buenos días,

    @GJAndroid Para que el giroscopio funcione debemos tener activa la opción "Girar la pantalla automáticamente" dentro de "Accesibilidad" y dentro de los ajustes de la pantalla.

    Por lo que comentas, entiendo que tú tienes activas ambas casillas, pero cuando reproduces la incidencia se desactiva la opción de "Accesibilidad" ¿es correcto?

    Un saludo.



  • No, sigue activa, pero para que funcione el giroscopio, tengo que desactivar y activar esa casilla


  • Administrador

    Buenas tardes,


    @GJAndroid ¿Con qué frecuencia te ocurre?

    Un saludo.



  • Puede variar, 2 veces al día, ninguna, o cada día


  • MVP

    En mi opinión deberías de comprobar si el acelerómetro (es el sensor que más influye en el giro de pantalla) funciona bien cuando no se produce el giro. Y también comprobar el giroscopio.

    Para ello, instala esta app:

    https://play.google.com/store/apps/details?id=com.cpuid.cpu_z

    Cuando el móvil no te gire, abre la app y vete a la pestaña: "sensores".

    En ella debes comprobar el funcionamiento de estos sensores:

    1. Para el "acelerómetro", cambia la posición del móvil entre vertical y horizontal fijándote si cambia los valores de la aceleración de la gravedad. Pasando de 9,8 m/s2 en su componente Y a 9,8 m/s2 en su componente X (en Z si apoyases el móvil sobre la mesa).

    2. Para el "giroscopio" comprueba que al balancear el móvil de su posición vertical (tanto hacia la izquierda como a la derecha) a la horizontal cambian sus velocidades angulares (rad/s) en las componentes X,Y y Z.

    Después, coméntanos los resultados....



  • @{GJAndroid}, además puedes probar otra cosa: saca la bandeja de la SIM y vuelve a meterla asegurándote de que queda bien fija y metida del todo. Es que esto que cuentas pasó en el M5 de mi pareja nada más comprarlo y resulta que fue eso. Un móvil, eléctricamente, es bastante delicado, no es normal que pasen estas cosas pero tampoco es imposible.



  • En mi opinión deberías de comprobar si el acelerómetro (es el sensor que más influye en el giro de pantalla) funciona bien cuando no se produce el giro. Y también comprobar el giroscopio.

    Para ello, instala esta app:

    https://play.google.com/store/apps/details?id=com.cpuid.cpu_z

    Cuando el móvil no te gire, abre la app y vete a la pestaña: "sensores".

    En ella debes comprobar el funcionamiento de estos sensores:

    1. Para el "acelerómetro", cambia la posición del móvil entre vertical y horizontal fijándote si cambia los valores de la aceleración de la gravedad. Pasando de 9,8 m/s2 en su componente Y a 9,8 m/s2 en su componente X (en Z si apoyases el móvil sobre la mesa).

    2. Para el "giroscopio" comprueba que al balancear el móvil de su posición vertical (tanto hacia la izquierda como a la derecha) a la horizontal cambian sus velocidades angulares (rad/s) en las componentes X,Y y Z.

    Después, coméntanos los resultados....


    He hecho lo que dijiste, y según CPU-Z, el giroscopio funciona correctamente, será fallo de software, supongo



  • En mi opinión deberías de comprobar si el acelerómetro (es el sensor que más influye en el giro de pantalla) funciona bien cuando no se produce el giro. Y también comprobar el giroscopio.

    Para ello, instala esta app:

    https://play.google.com/store/apps/details?id=com.cpuid.cpu_z

    Cuando el móvil no te gire, abre la app y vete a la pestaña: "sensores".

    En ella debes comprobar el funcionamiento de estos sensores:

    1. Para el "acelerómetro", cambia la posición del móvil entre vertical y horizontal fijándote si cambia los valores de la aceleración de la gravedad. Pasando de 9,8 m/s2 en su componente Y a 9,8 m/s2 en su componente X (en Z si apoyases el móvil sobre la mesa).

    2. Para el "giroscopio" comprueba que al balancear el móvil de su posición vertical (tanto hacia la izquierda como a la derecha) a la horizontal cambian sus velocidades angulares (rad/s) en las componentes X,Y y Z.

    Después, coméntanos los resultados....


    He hecho lo que dijiste, y según CPU-Z, el giroscopio funciona correctamente, será fallo de software, supongo

    Aunque esta vez se ha solucionado sólo


  • MVP

    En mi opinión deberías de comprobar si el acelerómetro (es el sensor que más influye en el giro de pantalla) funciona bien cuando no se produce el giro. Y también comprobar el giroscopio.

    Para ello, instala esta app:

    https://play.google.com/store/apps/details?id=com.cpuid.cpu_z

    Cuando el móvil no te gire, abre la app y vete a la pestaña: "sensores".

    En ella debes comprobar el funcionamiento de estos sensores:

    1. Para el "acelerómetro", cambia la posición del móvil entre vertical y horizontal fijándote si cambia los valores de la aceleración de la gravedad. Pasando de 9,8 m/s2 en su componente Y a 9,8 m/s2 en su componente X (en Z si apoyases el móvil sobre la mesa).

    2. Para el "giroscopio" comprueba que al balancear el móvil de su posición vertical (tanto hacia la izquierda como a la derecha) a la horizontal cambian sus velocidades angulares (rad/s) en las componentes X,Y y Z.

    Después, coméntanos los resultados....


    He hecho lo que dijiste, y según CPU-Z, el giroscopio funciona correctamente, será fallo de software, supongo

    Aunque esta vez se ha solucionado sólo

    Vale, entonces todo indica que ambos sensores están bien. Es lo que quería saber.

    Como bien dices, es software. No te vas a librar de restablecer a valores de fábrica. Haz copia de tus datos y restablece el terminal, sin copia de seguridad y configurándolo como dispositivo nuevo.



  • En mi opinión deberías de comprobar si el acelerómetro (es el sensor que más influye en el giro de pantalla) funciona bien cuando no se produce el giro. Y también comprobar el giroscopio.

    Para ello, instala esta app:

    https://play.google.com/store/apps/details?id=com.cpuid.cpu_z

    Cuando el móvil no te gire, abre la app y vete a la pestaña: "sensores".

    En ella debes comprobar el funcionamiento de estos sensores:

    1. Para el "acelerómetro", cambia la posición del móvil entre vertical y horizontal fijándote si cambia los valores de la aceleración de la gravedad. Pasando de 9,8 m/s2 en su componente Y a 9,8 m/s2 en su componente X (en Z si apoyases el móvil sobre la mesa).

    2. Para el "giroscopio" comprueba que al balancear el móvil de su posición vertical (tanto hacia la izquierda como a la derecha) a la horizontal cambian sus velocidades angulares (rad/s) en las componentes X,Y y Z.

    Después, coméntanos los resultados....


    He hecho lo que dijiste, y según CPU-Z, el giroscopio funciona correctamente, será fallo de software, supongo

    Aunque esta vez se ha solucionado sólo

    Vale, entonces todo indica que ambos sensores están bien. Es lo que quería saber.

    Como bien dices, es software. No te vas a librar de restablecer a valores de fábrica. Haz copia de tus datos y restablece el terminal, sin copia de seguridad y configurándolo como dispositivo nuevo.


    He hecho lo que dijiste y sigue igual, me acaba de pasar ahora mismo


  • MVP

    En mi opinión deberías de comprobar si el acelerómetro (es el sensor que más influye en el giro de pantalla) funciona bien cuando no se produce el giro. Y también comprobar el giroscopio.

    Para ello, instala esta app:

    https://play.google.com/store/apps/details?id=com.cpuid.cpu_z

    Cuando el móvil no te gire, abre la app y vete a la pestaña: "sensores".

    En ella debes comprobar el funcionamiento de estos sensores:

    1. Para el "acelerómetro", cambia la posición del móvil entre vertical y horizontal fijándote si cambia los valores de la aceleración de la gravedad. Pasando de 9,8 m/s2 en su componente Y a 9,8 m/s2 en su componente X (en Z si apoyases el móvil sobre la mesa).

    2. Para el "giroscopio" comprueba que al balancear el móvil de su posición vertical (tanto hacia la izquierda como a la derecha) a la horizontal cambian sus velocidades angulares (rad/s) en las componentes X,Y y Z.

    Después, coméntanos los resultados....


    He hecho lo que dijiste, y según CPU-Z, el giroscopio funciona correctamente, será fallo de software, supongo

    Aunque esta vez se ha solucionado sólo

    Vale, entonces todo indica que ambos sensores están bien. Es lo que quería saber.

    Como bien dices, es software. No te vas a librar de restablecer a valores de fábrica. Haz copia de tus datos y restablece el terminal, sin copia de seguridad y configurándolo como dispositivo nuevo.


    He hecho lo que dijiste y sigue igual, me acaba de pasar ahora mismo

    Has instalado alguna app o estás probando solamente con las de sistema??

    He releído tu comentario y decías que el giroscopio iba bien en CPU-Z pero y el acelerómetro, daba los valores indicados, tal y como te comenté?? Debes poner el móvil en las posiciones que te he indicado observando si cambian sus valores (cuando el móvil te da el fallo de no rotar).