Se puede calibrar el sensor de proximidad?



  • Hola a todos he notado que durante una llamada a veces cuando aparto el móvil de la oreja y voy a colgar la pantalla esta totalmente negra y no puedo colgar hasta que la otra persona cuelga y no es por que yo tape el sensor con el dedo sin querer ni nada por el estilo... alguien más lo a notado?? se puede calibrar el sensor de proximidad?? yo me acuerdo en un Zte skate que tuve que le pasaba lo mismo y calibrandolo se solucionó... salu2

    Enviado desde mi bq Aquaris usando Tapatalk 2



  • Parecerá coña, pero quítale los dedos, que seguramente tendrás cerca del sensor de proximidad y verás cómo se vuelve a encender, te lo digo porque no eres el primero que le ha pasado, entre ellos un servidor. :lol:

    Un saludo



  • yo juraría que no tengo los dedos cerca pero vamos a la próxima me fijaré más gracias

    Enviado desde mi bq Aquaris usando Tapatalk 2



  • Mi hermana me acaba de llamar y me ha dicho eso que la pantalla se apagaba y no podia colgar, le he dicho lo del sensor de proximidad y me ha dicho que si deja pulsado el boton de apagar se le vuelve a encender, ella probo pulsando todos los botones pero parece que es dejando pulsador el power.



  • Si se apaga la pantalla podrás encenderla con el botón de encendido.

    Puede ser que estés hablando y el sensor no esté actuando porque tienes el teléfono muy despegado de la oreja l el sensor en lugar de "ver" la oreja ve tu cabeza porque lo tienes muy hacia atrás (lado izquierdo de la cabeza) o muy hacia adelante (lado derecho de la cabeza) y el sensor intenta detectar tu sien. Al no encontrar nada se apaga la pantalla para que no estés todo el rato hablando con ella encendida.

    Prueba a ver.



  • Eso nos ha pasado a varios y es por la manera de coger el teléfono, hay veces que sin querer, abarcamos con la mano todo el teléfono y el sensor lo detecta como si aún estuviera pegado a la cara

    Un saludo



  • hola yo sigo experimentando lo mismo a veces se queda pillado el sensor de proximidad y cuando lo aparto de la oreja sigue estando negra la pantalla y no puedo colgar solo me pasa a veces y no tengo la mano cerca ni nada hasta he probado a agitarlo a ver si se activa la pantalla je je seria genial poder calibrar el sensor con un comando ;-)salu2

    Enviado desde mi bq Aquaris usando Tapatalk 2



  • ¿Sabéis dónde está el sensor?



  • [quote="Peterico"]¿Sabéis dónde está el sensor?[/quote]
    arriba a la izquierda no?

    Enviado desde mi bq Aquaris usando Tapatalk 2



  • Sí, pero no exactamente pegado a la izquierda y muy pegado al borde, con lo que si lo cogemos al revés o le ponemos el dedito índice (o dedazo en mi caso), por arriba, le engañamos o confundimos, diciéndole que lo tenemos cerca, si lo cogemos totalmente por debajo no pasa eso.

    Un saludo



  • Es la barrita negra que se ve al lado del altavoz.

    Daros cuenta que la parte plata es por donde sale la voz de con quien hablamos y si, por ejemplo, desplazamos el móvil (de forma involuntaria, claro está) y a la altura del canal auditivo dejamos la cámara el pabellón de la oreja queda con el altavoz y el sensor fuera de la oreja.



  • Uo pensaba que la barrita negra era el sensor de luz :S



  • A mi no se me apaga la pantalla al hacer una llamada, puede ser cosa del protector o sensor estropeado? Si pongo el dedo encima del sensor se deberia de apagar no?

    Enviado desde mi bq Aquaris usando Tapatalk 2



  • Hola,
    Si se tapa con el dedo también se debería apagar, pero ten en cuenta que solo se apaga mientras estas haciendo una llamada, si lo pruebas sin llamar no se va a apagar.
    Prueba a taparlo con el dedo, sin confundir con la cámara, mientras haces una llamada para comprobar si funciona.

    Saludos,



  • Es un problema generalizado, con el móvil en colocado en la mesa he probado a llamar por teléfono y automáticamente se apaga la pantalla, sin acercar el dedo ni la cabeza al sensor, y por supuesto sin tapar nada de manera involuntaria ya que el móvil está en la mesa. Después de estar mirando los sensores detenidamente con ayuda de la luz de una linterna y de limpiar muy bien la pantalla, ha empezado a funcionar el sensor. Esto último lo he estado comprobando con una aplicación que me testeaba el sensor. 


    Creo que no está demasiado bien calibrado el sensor, y por alguna razón funciona a veces sí a veces no. A ver si sale algo para que se solucione... Muchas gracias!

    Un saludo!



  • Hola @jdsl,

    No es un problema generalizado. Si no quieres que se apague la pantalla en una llamada larga con el móvil en una mesa, entra en Ajustes/Pantalla/Suspender y lo pones en 30 minutos. De esta forma a no ser que te acerques el móvil a la oreja y por tanto tapes el sensor o pase la llamada de esos 30 minutos, no se apagará la pantalla.

    Saludos,



  • serrano dijo:
    Hola @jdsl,
    No es un problema generalizado. Si no quieres que se apague la pantalla en una llamada larga con el móvil en una mesa, entra en Ajustes/Pantalla/Suspender y lo pones en 30 minutos. De esta forma a no ser que te acerques el móvil a la oreja y por tanto tapes el sensor o pase la llamada de esos 30 minutos, no se apagará la pantalla.

    Saludos,
    Ante todo muchas gracias por la respuesta, pero obviamente ese parámetro lo revisé, lo tengo configurado a varios minutos y cuando digo que automáticamente se apaga la pantalla es que de forma inmediata (1 segundo aprox) se apaga tras dar a llamar. De todas formas he realizado pruebas en entornos con poca luz y con luz del día y el comportamiento dista mucho de ser el correcto ya que responde a duras penas cuando le acerco la mano al sensor, he utilizado las apps Proximity Screen Off y Android Sensor Box. Actualmente tengo la versión 1.1.3 desde hace más de un mes si no recuerdo mal y me parece recordar también que antes de la actualización no tenía ese problema. Con la versión 1.1.4 se puede solucionar? he leído algo de que se incluían unos nuevos drivers...

    Gracias de nuevo


  • Es el mismo que el 1.1.3 por lo que en este caso sería lo mismo. Lo que puedes probar es reinstalar el firmware vía hard reset, En este caso tienes que descargar la 1.1.4 desde aquí. Tienes un vídeo de como hacerlo aquí.


    Saludos,



  • Serrano dijo:
    Es el mismo que el 1.1.3 por lo que en este caso sería lo mismo. Lo que puedes probar es reinstalar el firmware vía hard reset, En este caso tienes que descargar la 1.1.4 desde aquí. Tienes un vídeo de como hacerlo aquí.

    Saludos,
    Muchas gracias, probaré a ver si se soluciona reinstalando vía Hard Reset. Ya os contaré.


  • jdsl dijo:
    Serrano dijo:
    Es el mismo que el 1.1.3 por lo que en este caso sería lo mismo. Lo que puedes probar es reinstalar el firmware vía hard reset, En este caso tienes que descargar la 1.1.4 desde aquí. Tienes un vídeo de como hacerlo aquí.

    Saludos,
    Muchas gracias, probaré a ver si se soluciona reinstalando vía Hard Reset. Ya os contaré.

    Buenas noches a todos, al realizar el HR no se solucionó el problema con el sensor de proximidad, aunque he escrito mi opinión sobre cuál podría ser la razón del fallo en el siguiente hilo:


    Un saludo.