Cambio conector H0 Zum Mega 3D



  • Hola, he adquirido de segunda mano una hephestos 2 y despues de dos o tres impresiones el extrusor no calienta. Al abrir el hueco donde esta la placa descubro que el conector esta quemado porque se ve que el antiguo dueño ha hecho una chapuza empalmando el cable y dejando el cobre al aire por lo que se ha cortocircuitado y ha quemado el conector. He cortado el conector porque con un soldador no he conseguido fundir el estaño de los terminales a pesar de que he conseguido otro conector nuevo. Otra opcion es cambiar el firmware para que caliente por E1 en vez de por E0, el problema es que tengo el codigo fuente de la version 2.5.3, pero no consigo que se me cargue en la placa al ejecutar make. Me podeis explicar como cargar el firmware del codigo fuente??


  • MVP

    Para retirar el estaño que te ha quedado, puedes usar un trozo de cable de cobre, calientas como si lo fueses a soldar y estando con el soldador calentando, lo retiras, así se va llevando los restos.

    Para compilar el firmware, una vez modificado, qué error/errores te da?



  • @lucky ya he intentado retirar el estaño varias veces pero no se funde y es desesperante, tampoco le he querido meter mucha temperatura por miedo a cargarme la placa. Al no poder retirar el estaño pensé en cambiar el firmware para usar el conector E1, pero me esta resultado imposible. Te adjunto lo que me pone cuando ejecuto make, le doy al numero 7 y luego marco el puerto COM que le ha asignado windows.


  • MVP

    Intenta una cosa por si acaso, copia toda la carpeta en la raíz del disco duro, en una carpeta con nombre corto y sin espacios ni puntos. Puede que te funcione, y comentas



  • @lucky le he cambiado el nombre a la carpeta por Hephe y la he metido en C:\, pero no se me carga ni noto que cambie algo en la pantalla de la impresora. La tengo conectada solo con el usb al ordenador para probarla pero instale make como ponia el github y sigue sin cargar el codigo fuente que hay en la web de BQ, probare a descargarme otra vez el codigo  fuente sin modificarlo y a meterlo en C:\ a ver si se carga. Creo que las deberia de haber un video tutorial en youtube o un pdf donde venga mas detallado los pasos a seguir para instalar el codigo fuente porque la verdad que no esta siendo algo facil.



  • He conseguido cargar el firmware, resulta que no se me había borrado la versión mas actual de arduino que tenia instalada y por eso daba fallo. Llevo unas cuantas hora viendo donde se edita el código para que en vez de calentar con E0 usar E1, pero no lo encuentro. Alguien sabe que archivo hay que editar?? Adjunto fotos de los que me saca make cuando cargo el firmware.


  • MVP

    Tienes que buscar un archivo que se llama pins.h que debería estar en una carpeta con el nombre de la impresora tuya.