No se puede instalar "Servicios de Google Play" (Código de error: -504)



  • Buenas tardes, ya sé que se ha hablado aquí de de este problema a la hora de instalar Google Play, pero el tema está cerrado y lo que se ha puesto no me sirve.

    Veamos, hace 1 semana tuve que resetear valores de fabrica en mi BQ Edison3 por un motivo con la conexión wifi, ya había reseteado la tablet muchas veces, pero esta ultima vez al instalar Google Play Juegos me pide instalar Google+ el cual se instala bien, (58,61MB y versión 11.2.0.269622364) después tengo:

    - Google Play Store: versión "16.6.26-ali [0] [PR] 268150575" y pesa 85,86MB

    - Google Play Juegos: versión 2019.08.12275 (265766886.265766886-000302 y pesa 39,13MB

    He probado de todo, desde borrar Datos y Caché a borrar la cuenta de Google, reiniciar y volver a añadirla, a borrar las actualizaciones, borrar las aplicaciones Google Play y Google+ incluso volver a valores de fábrica incluso quitando la tarjeta MicroSD... pero esto sigue sin dejarme instalar "Servicios de Google Play" por lo que por ahora en vez de tener una tablet tengo un bonito pisapapeles.

    En el apartado Aplicaciones/Todas aparece "servicios de Google Play" versión 8.1.15 (2250156-234) y 91,76MB lo cual me despista aún mas.

    Los datos de mi tablet son:

    Versión KitKat versión de Android 5.0

    Kernel:

    3.10.54+

    jenkins@bqbot1 #1

    Wed Dec 9 09:01:59 CET 2015

    Compilación:

    2.10_20151209-0843

    He visto un post que habla de instalar manualmente el apk, pero cómo lo hago y dónde lo encuentro? Que mas tengo que hacer? estoy por tirar la tablet por la ventana.

    Un saludo y gracias.



  • He encontrado este tutorial que quizás pueda ayudar, aunque en mi caso, aun no:
    https://www.xatakandroid.com/tutoriales/como-actualizar-google-play-services-o-instalarlo-desde-cero-si-tu-android-no-lo-tiene

    aseguran que apkmirror es segura y oficial de los instaladores para bajar el apk de Servicios de Google Play:

    https://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-19-2-75-release/#downloads

    Aparecen muchos, pero no se cual debo bajar, estoy probando ...... pero nada.

    Que martirio... Alguna ayuda?


  • Administrador

    Buenas tardes,

    @RafaGijon como sabes "Servicios de Google Play" es una aplicación que recibe actualizaciones periódicas por parte de Google. Si Google modifica los requisistos de dicha app puede ocurrir que ciertos dispositivos dejen de tener acceso a dicha app -esto mismo es lo que ocurrió hace meses y que se solucionó según apareció, mediante una nueva actualización por parte de Google- .

    Al tratarse de una app que gestiona Google directamente te recomendamos contactar con ellos a través del correo: apps-help@google.com

    No obstante, nosotros seguiremos haciendo pruebas para tratar de encontrar un método de instalación alternativo.

    Un saludo.



  • Muchas gracias AdrianC por responder, me imagino que esto será cosa de Google, lo que no entiendo es que funcionaba correctamente hasta el momento de resetear la tablet, 3 minutos después, al reinstalar, ya no. Mal vamos si una tablet queda obsoleta de un día para otro a los 6 años funcionando perfectamente... Voy a probar un hard reset como propone BQ en esta web:

    https://www.bq.com/es/support/help/631

    Luego os cuento, quizás esto sirva para los demás usuarios.


  • Administrador

    Buenas,

    @RafaGijon Lo que habrá ocurrido es que se han actualizado los Servicios de Google y eso ha sido el detonante.

    Entiendo que tienes una Edison 3 3G ¿me equivoco?

    El Hard Reset no te serviría de nada porque el problema está en los Servicios de Google y éstos se actualizan independientemente de la versión.

    ¿6 años? Si acaso 5... la Edison 3 3G salió a la venta el 27/11/2014. De todas formas un año es un abismo, imáginate 5 o 6 .... Yo, por ejemplo, tengo una Curie 2 Quad Core (6 años....) y te entiendo perfectamente. No obstante, poco se puede hacer si Google decide modificar X apps o servicios (y de paso que las apps dejen de funcionar....).

    En cuanto me confirmes el modelo exacto de tu tablet vemos si podemos hacer algo más.

    Un saludo.



  • Hola,
    A mi me pasa exactamente lo mismo, no me deja actualizar los Servicios de Google. Mi tablet es la Edison 3, carcasa negra, con la última actualización de Android que hay para esta tablet, Android 5 Lollipop. He realizado todos los pasos indicados en https://www.xatakandroid.com/tutoriales/como-actualizar-google-play-services-o-instalarlo-desde-cero-si-tu-android-no-lo-tiene, y nada. También he intentado instalar el apk manualmente, y sin resultados.

    Un saludo


  • Administrador

    Buenos días,

    @Canadier Por casualidad ¿esto te ocurre después de haber restablecido la tablet?

    A través de las pruebas realizadas hemos visto que cualquier actualización de "Servicios de Google" superior a la versión 16.8.66 no se instala. Con esa versión actualmente las apps de Google funcionan todas según lo esperado y sin ningún tipo de aviso o mensaje de error.

    Así mismo, os recomendamos que contactéis también directamente con Google: apps-help@google.com

    Un saludo.



  • @adrianc dijo:

    Buenos días, @Canadier Por casualidad ¿esto te ocurre después de haber restablecido la tablet? A través de las pruebas realizadas hemos visto que cualquier actualización de "Servicios de Google" superior a la versión 16.8.66 no se instala. Con versión actualmente las apps de Google funcionan todas según lo esperado y sin ningún tipo de aviso o mensaje de error. Así mismo, os recomendamos que contactéis también directamente con Google: apps-help@google.com Un saludo.

     Hola, tengo el mismo problema, he probado todo, instalar desde apk, borrar datos de servicios de google play y nada, no hay manera, alguna otra solución?  He probado también a instalar esa version de los servicios de google play sin éxito.


  • Administrador

    Buenas,

    @vicentecph Esa versión de servicios de Google es lo primero que hay que instalar en la tablet. Nuestras tablets están funcionando perfectamente desde entonces con esa versión de los servicios de Google. Después tienes que evitar que los servicios de google intenten instalarse automáticamente, sino podemos estar ante el mismo problema.

    Un saludo.



  • @adrianc como te digo, descargué el apk de esa versión de play services, pero da error al tratar de instalarla, si lo hago desde la tablet la instalación falla, y si lo hago por adb install, me da un failure de package already exists, así que ya me contarás como puedo instalarla... Gracias por responder.


  • Administrador

    Buenas,

    @vicentecph En ese caso habría que ir probando con versiones diferentes hasta dar con una que te funcione o esperar a que Google lance una revisión de los Servicios de Google con esto corregido (este problema ya lo tuvieron hace varios meses y lo solventaron con el tiempo).

    Un saludo.



  • @adrianc dijo:

    16.8.66

     Hola Adrian C, ¿me puedes decir como se llama exactamente la version 16.8.66 ? te pregunto esto ya que he visto que en la web de google salen varias versiones.

    Tu me puedes decir exactamente donde me la puedo bajar?

    Muchas gracias.

    Saludos, JOANGA



  • Tengo la Edison 3, no 3G, y no hay manera. Llevo un año con ella, y no ha dado más qu eerrores. Ya ha estado en BQ, y ha vuelto igual. Los Servicios de Google Play no se instalan, y eso hace que todas las aplicaciones dependientes no funcionen, y salgan decenas de mensajes. NO se instala nunca, siempre hay mensaje de error...he probado todo lo probable (hard reset, quitarla, instalarla, borrar caché, etc etc etc...) y sigue igual. Qué puedo hacer??



  • @beo lo único que es posible hacer, de acuerdo con lo indicado en el hilo, es esperar a que Google vuelva a solucionar la situación desde su parte. 



  • Ajo y agua, entonces??? No puedo usar la tablet??



  • @beo volver a KitKat con las herramientas de flasheo y un PC (o, directamente, desde la tablet si te da la opción) sería la única opción viable aquí.



  • Bueno instalando la version 16.8.66 por lo menos puedo volver a usarla....



  • @franjoc gracias por indicarlo 🙂 Si esto puede servir como solución, bienvenido sea. 





  • También funciona la 17.1.22 variante 020304.