Slow to wake from sleep

  • Hi, 

    I have a problem with waking device if it was locked for a longer time. It takes more than a minute for it to turn the screen on after pressing the power button. After that everything works perfectly... 

    If it is important it was originally the Ubuntu version, now flashed to the latest official android firmware. 
  • 15 Answerssorted by
  • fixit
    fixit
    Member  (12)
    @Niksavel. I would recommend you to close all the apps (Button on the bottom right side), clean the whole cache (settings > Storage > Cached Data) and reboot the system. I would also remove the SD to check if the SD could be causing the issue.
  • Tried that no change.

    Tried full wipe and factory reset from bootloader.
    No change.

    After further study, this is happening when waking from "deep sleep" ...  the tab needs to be closed for at lest 30 min ...    

    Found a lot of users of another brand complaning of 2-3 second wake from deep sleep lag, but let me just state again, this is up to 1 minute 30 seconds lag. It is quite unacceptable. 

    I will try with wakelock installed (no deep sleep) and one more hard reset without any installed apps and see what happens.
  • Update: installed wake lock app and set it to partial wakelock so it never goes to deep sleep. Problem disappeared entirely. Found several forums with nexus users experiencing the same issue after update to Android 5.1
  • beatricezfs
    beatricezfs
    Moderator  (56)
    Hi @Niksavel

    Did you try to restore your device to factory settings?

    It can fix the issue without the need to use specific app.

    When the device is restarting from the restore, in the step "get your data and apps" in "backup my data" you should select the option "configure as a new device".

    Regards, 


    Beatrice

    BQ Technical Support

    Official Support Channels:       Phone Assistance Monday to Friday from 8:00 to 17:00        Formulario-de-soporte_inglaterra.png
  • Yes I did. I did a full data format and reset from the bootloader.

    When it finally rebooted, I did allow google to reinstall all my apps from the backup, but it is full download and reinstall - which I would do manually anyway so I don't think that is the problem - no?


    In any case, i can confirm that with the wakelock app set to partial wakelock the device works perfect. Battery usage in standby is something like 0,6% pet hour.


    Let me just add that this is my first BQ device and I am really pleased with the performance and build quality, as well as official support for flashing android and ubuntu firmware and persisting warranty for rooted devices. I will definitely recommend this to friends.
  • A Ossorio
    A Ossorio
    Moderator  (197)
    Hi @Niksavel,

    Many thanks for letting us know.

    It is great to learn that the tablet is running smoothly now.

    For some reason, after a hard-reset process, a factory reset may occasionally be needed in order to normalise the installation and come to a completely stable install.

    We are really pleased that you are satisfied with the device and our warranty policies. Our goal is of course that you would be happy and would recommend our products to your friends ;)

    If you come across anything unexpected or need advice on any aspect of the tablet, you know where we are.

    Regards,
    A. Ossorio

    BQ Technical Support

    Official Support Channels:       Phone Assistance Monday to Friday from 8:00 to 17:00        Formulario-de-soporte_inglaterra.png
  • Hi A Ossorio,

    I have the same issue, when the tablet go to sleep it take very long time to wake up. As I do have a lock parttern, it freeze one or to time between pressed button and usable home screen.
    As it is the tablet is unusable. any guess ?

    I did factory reset the device several times as you mentioned earlier but with no success.
    The Tablet is the M10 FHD ubuntu edition flashed with your Android image (Ubuntu Touch is not really not ready yet, despite the great work you've done to port it to your device.)

  • Install Wakelock app (https://play.google.com/store/apps/details?id=eu.thedarken.wl&hl=en) and put it in partial wakelock mode.

    Works like a charm.   No significant battery drain...  in standby it's something like 0,5% per hour according to GSAM
  • I've been having a similar problem. After waking I type in my PIN but then the device freezes and I have to reboot. I'm not acquainted with the different modes but I'll try Wakelock.
  • Wakelock is a good workaround. I use the flag PARTIAL_WAKE_LOCK lower flags do not seem to work well.
  • One Year later as You started this topic I also installed Android on my M10 FHD and have the same problem. Under Ubuntu it took about 2 seconds for the screen to wake up. Under Android as mentioned above over a minute. And this minute is only needed for the display. When display wakes up device hangs and doesn't react for another 2-3 Minutes.
    If You have no solution I'll install Ubuntu again. No apps but the device will work at least.

    A few days ago Canonical announced that they will no longer support Ubuntu Touch. So after a Year I'm left alone with useless 300euro toy: either not working Android or poorly working Ubuntu ;-(
  • After updating to the latest firmware the problem went away. I am still very happy with my tab running Android.
  • After updating to the latest firmware the problem went away. I am still very happy with my tab running Android.


    And what is "the latest firmware"? I downloaded two days ago the 5.1 from bq website and i'm rather not " happy". If anyone else has this problem I can recommend connecting to the charger. The app mentioned above is written by a private person from Korea who wants root privilidges from my device. :-\ Sorry I'm not gonna give it to him.
  • Will take a look later today and let you know. Really works fine now
  • Build number is 1.3.0_20160228-2235